Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

NIMAX/LabVIEW Issue with Agilent E5071C ENA

Go to solution

I set my Agilent/Keysight 5071C up on a LAN and downloaded drivers. The 'Status' field in NIMAX says that the device is 'Not Present'. However, If I tab over  to the 'Web Page' tab, NIMAX has the device's web page loaded(?). It successfully pings as well. 


I downloaded the driver package and tried using a few of the VIs. The VISA Open commands in the sub-VIS are returning the fairly standard 1073807252 (Hex 0xBFFF006C) 'Device not present' error. 


As for experience.... I took LabVIEW Core 1 and 2 last month so I'm fairly new.

0 Kudos
Message 1 of 6



  1. Did you perform any steps to add the device in NI MAX? 
  2. Do you have Keysight VISA installed on this machine also? 
  3. How are you connected to this device? It is over a routed network? Are both your computer and the device on the same subnet?

Have you tried performing a reset on the NI MAX database?


0 Kudos
Message 2 of 6

1. I added the device manually with NIMAX via the IP address. The AutoDetect feature didn't find it.

2. We have something called Keysight 'Connection Expert' and 'IO Control' installed.  I see something indicating that "32-bit Keysight VISA is Secondary". From the looks of things, I would need to add it manually to their VISA or device manager.

3. Yes, it is over a routed network and we're on the same subnet. 

4. I haven't reset the database but I'm not getting any of the errors that the link you attached have listed.   





0 Kudos
Message 3 of 6



  1. Trials: 
    1. Have you tried removing/re-adding this device manually in NI MAX? 
    2. There was a similar thread in an old forum post: LINK TO FORUM POST. The solution was to clear said Aliases by going to MAX -> TOOLS ->  NI VISA ->  VISA Options on the pop-up window go to My System ->  General Settings ->  Aliases and on the bottom of the screen press "clear All Aliases". Could you please try this out? 
    3. Please check if the  "NI Device Loader" services is running in Windows Services. If not, please start it. 
  2. Further questions:
    1. Could you please share with us some screenshots of what you see in NI MAX as well as the error showing in LabVIEW?
    2. Does the VISA resource for this device show up in LabVIEW? 
  3. Additional Information: 
    1. In case you are going to install the KeySight VISA, please take into account it shared the same DLL with LV VISA, which may cause conflicts, I'd recommend you checking: This link to Dual VISA implementation.


0 Kudos
Message 4 of 6

I got a case ID from an NI engineer who pointed me to Keysight. I updated the E5017C firmware (9.10 to 11.34) and used an old version of Agilent Connection Expert (Version14) running on the machine to properly set up the instrument as a VISA resource (a few of the steps weren't inherently clear).  My understanding is that this process is easier in on the later versions that shipped loaded with Windows 7 and newer versions of Agilent Connection Expert. After going through all of that, NI Max picked it right up with 'AutoDetect'.  Alejandro from NI and Tom from Keysight were really helpful. 



Message 5 of 6
Accepted by topic author deckermw

To elaborate a little bit, after making sure that SICL-LAN Server was enabled in the ENA's instrument GUI, I needed to configure it in Agilent Connection Expert. 


What had me confused was the need to add a different IP address than the LAN IP address when 'adding the instrument to the LAN'.  I was expecting 192.168.X.Y but had to enter when performing the 'Add Instrument' under LAN resources in Agilent Connection Expert. Keep in mind, this is Version 14 of Connection Expert and newer versions might be more intuitive.


I guess the machine has an internal address for the instrument and one for the LAN. I obviously don't understand this very well but at the end of the day, NI MAX can find it and the VIs are talking to it as a LAN VISA resource. 

0 Kudos
Message 6 of 6