Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

NI-VISA installation freezing on 64 bit Windows 10?

Go to solution

When trying to install NI-VISA 16.0 on Windows 10 (64-bit OS and 64-bit processor), NI's installer gets about 90% of the way through installation and then my PC freezes completely (i.e. Screen doesn't update, no mouse or keyboard interaction, need to restart my PC) and it fails to install.


I tried installing uninstalling all NI products and installing an earlier version of NI-VISA (15.0.1) just to see if that would work and received an error popup during install:

The "VISA.NET Shared Components 64-Bit" installation has failed with the following error:

VISA Shared Components 5.5 or higher must be installed before installing VISA.NET Shared Components.

According to IVI, these Shared Components should be included in the NI-VISA install from the vendor (i.e. NI), but apparently aren't or can't be found by the installer.


Anyone have any ideas on this or have any success installing NI-VISA 15.0/16.0 on Win 10 64-bit?




0 Kudos
Message 1 of 6
Accepted by topic author bd8



May I ask where you are installing NI-VISA 16 from? I would recommend downloading NI-VISA from the following link .


NI-VISA 16.0 - Pharlap ETS, NI Linux Real Time, VxWorks, Windows 10/8.1/8/7/Server 2012 R2 64-bit/Server 2008 R2 64-bit


When you have that downloaded, it would be helpful to install it while started in Safe Mode to prevent any startup applications from interfering with the installation.




Shamik C

Applications Engineer 

National Instruments 



0 Kudos
Message 2 of 6


I'm having the same problem, but I'm installing NI-VISA 17.5, which I have downloaded form NI NIVISA1750full.exe, installing into A WINDOWS 7 64 Bts OS 


0 Kudos
Message 3 of 6


I'm replying to my own post, this is how I solved. 


Since I'm working with an Agilent Technologies instruments 53210A, 34970A & 8648C; what I did was to install Agilent Technologies IO Libraries IOLibSuite_18_1_23218.exe then I was able to install NIVISA1750full.exe


Hopefully this helps. 



F Casian 



Message 4 of 6

I'm having the same issue on my installation.  Did you ever find a resolution?

Mark Randel
Software Guy at SpaceX

Certified LabVIEW Architect Certified LabVIEW Architect Certified LabVIEW Architect

0 Kudos
Message 5 of 6