Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

NI-MAX shows wrong model for one instrument

We normally clone some machine with all our software installed to get a new one, change its name, etc. For some reason MAX seems to remember some of its old configuration and refuses to acknowledge that an instrument at a certain GPIB address is no longer the instrument there.

 

It shows the old Vendor, Model, Serial Number and Firmware Version.  Opening the Communicate with Instrument or VISA Test Panel, and sending *IDN? to the instrument there, returns the new values. If I start IO Trace, select the GPIB bus in MAX and do a scan for instruments, I can see the correct value being returned, but MAX doesn't update the corresponding entry.

 

This is Windows 10, MAX 20.5.  I've Reset the Configuration Data several times, sometimes from a MAX running as me, sometimes running as Administrator, with the corresponding reboots.  I've manually stopped all NI services and wiped out the DATA directory under c:\ProgramData\National Instruments\MAX, followed by reboot.   The old data always returns.

 

We can talk to the instrument at that address just fine, it is just MAX that keeps showing the wrong instrument!

 

 

0 Kudos
Message 1 of 2
(717 Views)

Some data displayed in NI-MAX is not cleaned by resetting the configuration data, maybe because it is not gathered by NI-MAX.

 

There are (at least) two files c:\ProgramData\National Instruments\NI-488.2\gpib.ini and c:\ProgramData\National Instruments\NIvisa\visarsrc.xml that are not cleared/reset, at least visarsrc.xml is not.

 

That file keeps model information for instruments, as displayed in the left frame of NI-MAX.

 

Now for my guess of what happens:

  • The code that extracts the model number to be displayed, and stored in visarsrc.xml, sometimes cannot parse the string returned by a *IDN? query.  And in this case it probably should, as the string returned clearly contains MODEL XXXX in it.
  • When that happens NI-MAX shows it as InstrumentN, N being a number, the same thing it does with instruments that don't reply to *IDN? It also does not write anything back to visarsrc.xml.
  • Also in this case, if visarsrc.xml contains an old entry for an instrument at that GPIB address, NI-MAX readily displays that as the current instrument in the left frame, and shows the old values it parsed out as Vendor, Model, Serial Number and Firmware Version in the right panel.

Removing visarsrc.xml, rebooting, re-scanning the bus for instruments, a couple of times, seems to fix this, but another 10 minutes of programming by someone at NI (and 2 months of QA) could probably solved it for everyone in the future.

 

0 Kudos
Message 2 of 2
(675 Views)