Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

NI 488.2 software failing Troubleshooting Utility

Go to solution

I am unable to control my instruments using my known good software and a known good GPIB-USB-HS controller.  I am using Teststand to call VB6 and VB.NET code which is working on other PCs.  I am running Windows 7 and using NI 488.2 version 2.8.


NI MAX identifies the controller and my instruments.  I am able to communicate with my instruments through NI MAX.  However, the Troubleshooting Utility shows that the software is failing. 




The "Help" button provides the following:


Unknown NI-488.2 Software Error
An unknown NI-488.2 software problem has occurred. Try the following to resolve the problem before calling National Instruments:

Restart your system.
Run the NI-488.2 Troubleshooting Utility again.
If you still have the problem, try the following:

Repair the NI-488.2 for Windows software.
Restart your system.
Run the NI-488.2 Troubleshooting Utility again.


Obviously, these steps did not solve the problem.


My software is unable to get a handle to the controller and my function calls do not populate anything in NI-SPY.


I tried installing the latest 488.2 version (3.1.1) which did not help.  I tried uninstalling all NI software and then re-installing only the 488.2 software.  That did not help either.


Any thoughts?

0 Kudos
Message 1 of 4



The best place to start would be to follow this KnowledgeBase article:


Specifically verifying that the key "GPIB-32.dll" is present. Once this is ruled out, additional issues can be investigated. If this does not work could you also show a test which fails with NI-488.2 (3.1.1)?

Evan See
National Instruments
0 Kudos
Message 2 of 4

Hi Evan

Here is the NI-488.2 version 3.1.1 result.




I verified that gpib-32.dll is contained within the C:\Windows\System32 folder.


Today we swapped out the PC and have the system up and running.  I feel like wiping the hard drive on this affected PC and starting over will probably get it going.  I was hoping someone had run accross this failure and had a known fix.





Message 3 of 4
Accepted by topic author slindblo

I found the solution to this problem.


We are using an ICS Electronics modbus to GPIB converter to talk to a Watlow F4 thermal chamber controller.  The ICS module comes with a utility and drivers.  We don't need that software but our technician installed it anyway.  Part of that install includes a file called "gpib-32.dll".  The NI software also uses a file called "gpib-32.dll".  Our NI software was failing because it was accessing this library and finding something completely unexpected.  I replaced the .dll with one from a working install and that corrected the problem.


Interesting that neither the "Repair" nor "Uninstall/Re-Install" could correct this problem.


By the way, gpib-32.dll is not in C:\Windows\System32 on my Windows7 installs.  It is in C:\Windows\SysWOW64\.



Message 4 of 4