Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

My Basler acA2040-180km NIR is not visible in NI MAX

Solved!
Go to solution

Hello,

 

I am trying to set up my new area scan camera (Basler acA2040-180km NIR) using camera link. However, I can not see the camera in the Measurement and Automation Explorer (version 5.4). I'm guessing it has something to do with the drivers. When I installed the Basler pylon Camera Software Suite, the frame grabber detected the camera as "cam0: Basler GenICam Source". When clicking it, error appears saying "Error 0x80004005 The error code passed into imgShowError is unknown." But when using the pylon viewer (64-Bit), the camera is nowhere to be seen again in the device window.

 

The NI website says that it supports acA2040-180km (for grabbers PCIe-1433 and PXIe-1435), which I assume differs only in a way that it has a slightly different CMOS.

 

The frame grabber that I'm using is NI PCIe-1473R with FPGA circuit on it. I'm running 64-Bit Windows 7 Professional with Labview 2012 SP1 including the latest NI FPGA module with patches.

 

So far I have:

 

  • Updated the device drivers (February 2013)
  • Updated the Vision Acquisition software to version 5.3
  • Updated the NI-IMAQ to the latest version

Since I still consider myself as a novice when it comes to Labview and Labview programming, is there something simple that I have overlooked? Thank you in advance

 

Best,

 

Kari

 

 

 

 

Download All
Message 1 of 10
(7,381 Views)
Solution
Accepted by Garzaa

Hi Garzaa,

 

I already replied you through our Support channel but I copy here the answer so that everyone can benefit !

 

The NI PCIe-1473R Frame Grabber contains a reconfigurable FPGA in the image path enabling on-board image processing. This means that the full communication between the camera and the frame grabber goes through the FPGA. It is then a major difference comparing to the other standard frame grabber without FPGA. 

It means also that the camera will not shows up in Measurement & Automation Explorer.

With this frame grabber, you have to build and use an FPGA VI to use the camera.

 

However, it is still possible to control the camera from the host computer by a third party application (like Pylon for example) if needed. You can do this by routing the Serial link through the FPGA to the host computer. Then, on the host you need to run the Serial Server which serves as a serial-TCP interface. Finally, you can use the CameraLink Serial Remote System Selector tool in MAX (in MAX select "Tools" menu, then "NI Vision", then "Select CLSerNat Systems") to create a virtual serial port that you can use in any application to communicate with your camera. See some information here: http://digital.ni.com/public.nsf/allkb/A56C0DAD5FD5B23286257A61005DF16F?OpenDocument 

The FPGA VI and Serial Server that you need are already included with all the Vision-RIO examples shipped with the NI 1473R. The best advice is then to start with an example to see how it is working.

 

Kind regards,

Cédric | NI Belgium
Message 2 of 10
(7,309 Views)

Can LabVIEW be used to configure the camera through this virtual serial port (i.e. using IMAQ?)? It seems a shame if we have to use a 3rd party tool (Pylon)?

0 Kudos
Message 3 of 10
(7,057 Views)

Hello D*,

 

Yes, you can use LabVIEW to access the virtual serial port (as any serial port). 

You cannot do it using IMAQ for RIO frame grabber (the IMAQ Serial Write function works with non-RIO frame grabbers).

However, you can use VISA to do it.

 

Here is an example using IMAQ --> https://decibel.ni.com/content/docs/DOC-5049

It shouldn't be too complicated to convert it to VISA.

 

Kind regards,

Cédric | NI Belgium
Message 4 of 10
(6,982 Views)

Hello,

 

I know the topic is already solved, but I'm really new at LabView and I am working as a student at the University with this program the first time. I habve the same problem, but I don't really understand the solution. Could someone explain how to create this virtual  serial port?

 

Kind Regards

Piepe

0 Kudos
Message 5 of 10
(6,391 Views)

Hello Piepe,

 

Can you tell which part of the explanation provided by Cédric in his first post (marked as solution) is unclear?

It is explained in that message how you can create the virtual serial port.

Kind Regards,
Thierry C - CLA, CTA - Staff R&D Engineer, RF Semiconductor Test - National Instruments
If someone helped you, let them know. Mark as solved and/or give a kudo. 😉
0 Kudos
Message 6 of 10
(6,317 Views)

Hallo all,

 

i`m doing a project at the university with a frame grabber PCIe-1473R and i have a JAI CV-M2 as a camera at my disposol. So far i understood that the examples are ready to try if everything is OK. I tried to run the example to see how the system should work, but have the following problem Error ... I`m uploading the picture to see what exactly the problem is. Could it be that my camera is broken or not right for the example.

0 Kudos
Message 7 of 10
(6,035 Views)

Hello Genadi,

 

Can you create a separate forum post for this question?

It does not seem to be talking about the same type of camera, nor is it discussing a detection issue in NI MAX.

 

Thanks in advance!

Kind Regards,
Thierry C - CLA, CTA - Staff R&D Engineer, RF Semiconductor Test - National Instruments
If someone helped you, let them know. Mark as solved and/or give a kudo. 😉
0 Kudos
Message 8 of 10
(6,024 Views)

Hi Cédric, 

 

I met a similiar problem. When I tried to use my USB 3.0 camera (Basler acA640-120um) in MAX, I can only see it shows up and works well in an USB link named 'cam 1' (You can see it in attachment). In 'cam 0' part, it shows the Error 0x80004005 (See attachment). Therefore, when I use it in my Labview programme, in the camera area, it only shows blank page (see attachment). I suspect the problem is coming from the 'cam 1' thing. Can you help me with this? Thanks! 

 

Qi Li

Download All
0 Kudos
Message 9 of 10
(5,725 Views)

Hi,

 

One short question: If you write: ''You can do this by routing the Serial link through the FPGA to the host computer'', does it mean I have to physically connect it or in Labview?

 

Thank you very much.

 

Kind regards

Antonia

0 Kudos
Message 10 of 10
(4,929 Views)