Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

Missing CAN-FD Messages

Hello,

 

I have a CAN-FD setup with XNET and a CAN device from a company called PEAK.  My simulator transmits many CAN messages on the bus, two of which are CAN-FD  500Kb +2MB BRS, and ISO mode.  There is also an automotive ECU transmitting two CAN-FD messages and some others on the same BUS.

 

The Peak tool sees all of the messages, including the 4 CAN-FD messages(2 from the simulator and 2 from the ECU).  The XNET card, and or USB(8502) module only see the two CAN-FD modules from the ECU, and not the 2 from the simulator.

 

I'm sure it's not a termination or cabling issue, any other ideas?

 

Regards,

 

Terry Moss

 

 

0 Kudos
Message 1 of 4
(140 Views)

If you are sure that it is not a termination issue, did you measure the resistance between CAN_H & CAN_L?  What was the value?  Are you using the specified 120-ohm impedance cabling to properly handle the bus communications?

Help the Community (and future reviewers) by marking posts as follows:
If it helped - KUDOS
If it answers the issue - SOLUTION
0 Kudos
Message 2 of 4
(111 Views)

Hello,

 

My CAN Bus is as follows:

 

EBCard(120Ohm) -> NI CAN breakout box->(120 Ohm)ECU  The cables are all NI CAN Cables PN 1931128B-02, I assume they are the correct characteristic impedance.  If I measure the bus resistance, it's ~60 Ohms.

 

The PEAK and NI-CAN Modules are attached at the breakout box with not termination, physical or software selected.

 

I made two screen shots to help clarify the issue. In the Peak_NI_CANFD the simulator is sending the data, there are 4 CAN-FD messages on the Peak Bus Monitor, but notice that 0x24 and 0x25 are not read by the NI Bus Monitor, they are on the Peak Bus Monitor with the correct update rate.

 

The PeakTX24and25_NI_CANFD is with 0x24 and 0x25 switched off in the simulator, and transmitted from the Peak tool.  In that case the NI Bus Monitor sees the messages.

 

Thanks for you time and help.

 

Terry Moss

 

 

Download All
0 Kudos
Message 3 of 4
(106 Views)

Updated Status: The Automotive ECU reads the data correctly from the Simulator that transmits over the ElektroBit Card.  Only the NI tools do not work.

0 Kudos
Message 4 of 4
(94 Views)