Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

MAX crashes when trying to connect to remote VISA server

Solved!
Go to solution

Hi,  I am running into a problem with NI MAX while trying to setup a VISA server/client system.  I had first tried VISA server 4.3 but it would not even allow me to save the port settings on the server.  When I tried to connect to the server, the from a remote machine to access the RS232 ports, it would either crash NI MAX or do nothing depending on how I tried to set it up.  If I right click on the Remote System on the right configuration pane and follow the wizard through, it does not do anything, if I go to the tool bar to Tools-NI VISA-VISA Options and follow the wizard through, NI MAX crashes upon completion.  I then went online and got the lattest 4.4.1 version and tried that with the same results.  I am also experiencing anomolies in saving some configurations in NI MAX leading me to question if there are some privileges issues.  The OS is Windows XP Pro with SP2 on all machines.  I am logged on with administrator rights and everything appears to have full read/write privileges yet I still run into problems.  As to the problem of saving the port settings I tried manually setting the settings as described in

http://digital.ni.com/public.nsf/allkb/8EBAEC8A57BB48BE862574F90072D3DD

but with no success in version 4.3 but it did work fine when I upgraded to 4.4.1 with no changes to rights or privilages so some things seem kind of odd.  Any help would be greatly appreciated.

Hardware  Dell computers with Windows XP Pro and SP2

                  The server computer has a 16 port Rocket port RS232 port board

                  I will be accessing the ports with a program written in LV7.1 but I have not gotten to that point yet

                  Network is fine, I can ping the server computer from the client computer and the permissions are set in the server and the client is pointing to the right machine.

 

Thanks

CS

 

Message Edited by CHS on 12-10-2008 11:45 PM
0 Kudos
Message 1 of 3
(2,728 Views)

Hi,

 

Thank you for your post.  There is a known issue with MAX crashing when you right-click on a remote server.  This is documented in the KnowledgeBase here.  This is a bug that should have been fixed with MAX version 4.5.  MAX 4.5 should have been installed with VISA 4.4.1.  Which version of MAX are you using?  You can check by going to Help»About in MAX.  If you don't have MAX 4.5, reinstall VISA 4.4.1 and ensure that MAX 4.5 is included in your installl.

 

Have a great day!

 

Regards,

 

Todd V.

National Instruments
Applications Engineer
NI Prototyping Community
0 Kudos
Message 2 of 3
(2,709 Views)
Solution
Accepted by topic author CHS
Thanks for the reply.  We are using MAX 4.5  so that was not the problem.  We are not exaclty sure what the problem is/was other than it cured itself when we uninstalled everything and deleted the VXIPNP directory and reinstalled everything.  When we did this everything came up and worked the way it should.  One thing that may or may not be relevant is that when I was setting up the clients, I went through the Tools-NI VISA-VISA Options to complete the setup rather than right clicking on Remote Systems.  Previously, this would cause MAX to crash when completing the wizard so I though it would be a good test when I set up the first one and since it worked, I followed that procedure on the rest of the computers.  Either way the problem is solved and it is working.  Thanks again for the input.
0 Kudos
Message 3 of 3
(2,694 Views)