Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

MAX can't detect extra onboard serial ports on RT target

I'm having a problem with MAX detecting extra com ports on an x86 compatible motherboard with 10 serial ports. The ports are all shown up on BIOS. But when I proceeded to install Labview RTOS (Phar lap) on this board, and tried to connect to the target through MAX, the program could only see two ports. When I tried to Create New Port on this target using ASRL3::INSTR and validate it, MAX popped an error:


    Unable to open session to "visa://"


    Return status code: 0xBFFF00A8



    Access to the resource or remote machine is denied.

    This is due to lack of sufficient privileges for the current user or machine.


I'm using LV 2010 and NI Serial 3.6. Anybody is knowledgable of this problem? Is there a way to enter the bios address directly to MAX?


Please help!

0 Kudos
Message 1 of 9
NI-Serial supports COM1 and COM2 as built-in serial ports on PXI and Desktop RT controllers. Additional ports can be added using NI PCI, PCIe, PXI, or PXIe serial boards. Your system appears to be very non-standard. Could you provide the following information, so we can understand more about your system?

1. Which motherboard is in use? Could you provide a link to the product page for it?

2. If the motherboard is used with Windows, are all the ports found with a default install, or do you have to install additional drivers?

-Jason S.
0 Kudos
Message 2 of 9

Hi Jason,


I use this board as an RT (for an embedded application):


The serial ports are provided by two Fintek Super IO chips. We thought at first that since the serial ports were shown up in BIOS, it should be trivial to interface with them, so it may not be correct anymore.


I haven't had a chance to install Windows on this board, so I'll have to check for it when I get to the office. 


By the way, I figured out the VI_ERROR_NPERMISSION error, I'm running a VISA server on the RT and I need to let other devices access permission. I'm still unable to set MAX to recognizie other serial ports, the error when I hit Validate now is:


   Could not open a VISA session to "ASRL3::INSTR"


   VISA error code 0xBFFF0011


   Insufficient location information or the device or resource is not present in the system.


I've search around the board and couldn't find much help.




0 Kudos
Message 3 of 9

did you got the solution?

i to have same problem if you know please help me.

0 Kudos
Message 4 of 9


Sorry to hear about this issue. Would you mind providing details about your specific hardware and software? Even a screen shot would be a nice addition. 

Ben D.
Applications Engineer
National Instruments
0 Kudos
Message 5 of 9

I have the same problem - Intel Atom board ( With 4 integrated COMs, but only two are visible in RT Target. Definitely there is no problem with hardware (I disabled the first two ports (COM1 and COM2) in BIOS - RT OK with COM3 and COM4 and vice versa with COM3 and COM4). So there must be problem with NI Serial - is there any chance to configure NI serial to support more than 2 integrated COM Ports? 

0 Kudos
Message 6 of 9

By default the /ni-rt/system/niserial.ini file that is installed on the target only has two built-in (NonPnpDevice sections) listed.  You can modify this file to add additional NonPnpDevices you just need to define the IRQ and base address that matches your additional ports.

0 Kudos
Message 7 of 9

I have tried to modify niserial.ini, but with no success. Do you have any working example or manual?

0 Kudos
Message 8 of 9

I looked, but I couldn't find the one that I created a few years ago.  


Note that after you update the INI file you may also need to go to MAX and find the target PC under Remote Systems, right click Devices and Interfaces » Serial, select Creat New Port, choose Serial Binding COM3 and COM4, set their ASRL Number(recommended values are 3 and 4), and give them Alias(recommend default value COM3 and COM4). 

0 Kudos
Message 9 of 9