Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

LeCroy WaveRunner 610Zi USB

Go to solution

I have the 'scope mentioned in the subject line connected by USB to a Windows 10 64-bit system with NI-VISA 18.5. When I run NI-MAX, the 'scope shows up in the "Devices and Interfaces" list as VISA resource "USB0::0x05FF::0x1023::3205N59212::INSTR". When I open the VISA Test Panel and try to query the instrument ("*IDN?\n") it fails. Digging deeper with NI I/O Trace, it looks like the first half of the query, a viWrite operation, is failing: 0 bytes out of 6 are transferred.


If I swap in a Tek MDO4104B for the LeCroy, everything works fine.


I tried updating the firmware on the LeCroy 'scope to the latest version (, and it didn't make any difference.


Has anybody successfully used the USBTMC port on one of these WaveRunner 'scopes?

0 Kudos
Message 1 of 2
Accepted by topic author Bitdiddle

I needed to RTFM. The answer was in another thread here


Basically, there's a setting on the scope that has to be changed to enable USBTMC control


Utilities -> Utilities Setup -> Remote -> USBTMC


Turn it on and things start working.


Page 146 of the manual also mentions this

0 Kudos
Message 2 of 2