Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

Labview -time out error from LC8901A SRQ Set and LC8901A SQR wait for

Solved!
Go to solution

Hello from Greece!

 

I'm a new user to Labview. I'm trying to work with a camac crate with LeCroy 8901A.

 

While i'm using the driver functions LC8901A SRQ set.vi   i get the error 

 

1073676292

VI_SUCCESS_QUEUE_EMPTY

Operation completed successfully, but queue was already empty.

 

and  with LC8901A SRQ Wait.vi  the error

 

–1073807339

VI_ERROR_TMO

Timeout expired before operation completed.

 

I have just put the below functions in a queue

 

LC8901A Open --> LC8901A SRQ set --> LC8901A SRQ wait for

 

and I was trying to see from which slot the Look-at-Me was coming

 

Here is a report from NiSpy.

If somebody could help me!

Thanks anyway

R.

0 Kudos
Message 1 of 10
(7,199 Views)

Hi,

 

I don't know how much help I will be.  I have never used the CAMAC to GPIB device before and we (LeCroy) no longer offer support for this product (It was discontinued about 10 years ago).

 

That said, looking at the NI-Spy file, it appears that your first error is actually a warning (A command was sent to empty a queue that was already empty) if it doesn't stop the device, it is not an issue.

 

The next error looks like the device was performing an SRQ and did not get any response from any instruments before the timeout.

 

I don't know where or how the timeout is set but it may be that the instrument did not respond to the SRQ.

 

Hope this helps!

 

Leonard Brown

Applications Engineer

LeCroy Corporation

0 Kudos
Message 2 of 10
(7,188 Views)

Can you take a screen shot of the front panel when you run the VIs?  I would like to know what values you are passing into the controls.

 

Regards,

Jensen

Jensen
National Instruments
Applications Engineer
0 Kudos
Message 3 of 10
(7,166 Views)

I attached the screen shot. Hope it helps!

 

Regards

Rania

0 Kudos
Message 4 of 10
(7,139 Views)
Solution
Accepted by pulse_th

Do you have NI-VISA 1.2 installed?

Jensen
National Instruments
Applications Engineer
0 Kudos
Message 5 of 10
(7,122 Views)

I noticed it yesterday in this forum and I downloaded NI-VISA 4.2 for XP from the above link, with the rationale that the latest upgrade would be better than the previous.

 

http://digital.ni.com/softlib.nsf/websearch/E3CF3AF68DD1A2BE8625738000648691?opendocument&node=13207...

 

I read the instructions from the read.html file and changed the directory for installation to C:\Program Files\IVI Foundation\VISA.  I ran again the VIs and the same errors were occured.

But I can't find the installation neither in the Add/Remove Programs in the control panel nor at MAX. I can't understand what I made wrong. Isn't it supposed to find the installation there?

 

What can I do??

 

Thank you very much for your help

Rania


 


 

 

0 Kudos
Message 6 of 10
(7,112 Views)

I forgot to tell you that I have the same errors in Visa Interactive Control.

 

I have windows XP PRo 2002 with service pack 3, ni-482.2 version 2.8, ni-Visa drivers the one i mentioned and Labview 7.1. Could it be a compatibility problem with all these versions??Or i have to install something extra??

 

thanks again

Rania

 

 

0 Kudos
Message 7 of 10
(7,103 Views)

You can find information on compatibility for Labview here, and for drivers in the read me document on the download pages.

 

Labview 7.1 is compatible with Win XP.

 

NI-488.2 2.8 compatibility here. It looks like version 2.4 will work for you.

There could be problems if you installed this driver over NI-488.2 driver earleir than version 2.0

Upgrading from Released NI-488.2 Versions

This driver allows upgrades starting from NI-488.2 for Windows, Version 2.0, on Windows XP. To install over software lower than Version 2.0 on Windows XP, you must uninstall the lower version first. To uninstall on Windows XP, go to the Control Panel and select Add/Remove Programs.

 

And it is not compatible with Labview 7.1

This driver version is recommended for use with the following software:

  • NI-VISA 4.6.2 and 5.0
  • LabVIEW 8.5.1, 8.6.1, 2009, and 2010
  • LabWindows/CVI 8.5.1 and 2009
  • Measurement Studio 8.6.1 and 2009
  • Microsoft Visual C/C++ 6.0, 7.1, 8.0, and 9.0
  • Microsoft Visual Studio .NET 2003, 2005, and 2008
  • Microsoft Visual Basic 6.0
  • Borland C/C++ 5.02

 

NI-VISA 4.2 compatibility here.

I didn't find anything conflicting here.

 

See if getting all of the compatible software gets rid of the error, and let me know if the issue persists.

Jensen
National Instruments
Applications Engineer
0 Kudos
Message 8 of 10
(7,097 Views)

This is for MAX System Information

 

 

Operating System(OS)       Microsoft Windows XP Professional
OS Version                       5.01.2600
OS Info                             Service Pack 3
Processor                         Intel(R) Core(TM)2 CPU          6300  @ 1.86GHz / x86 Family 6 Model 15 Stepping 6 / GenuineIntel / 1868 MHz
Number of Processors        2
Physical Memory              1.99 GB of RAM
Drive C:\                           446 GB of 465 GB free
                                    
National Instruments Software:      Version:
                                    
CVI                                      5.5
CVI Run-Time                       9.1.0.428
NI-DAQmx                            8.7.1f3
NI-488.2 Software                 2.80
IVI Compliance Package       3.1
LabVIEW                             7.1
     Advanced Analysis          7.1.0
     Application Builder            7.1.0
Measurement & Automation Explorer   4.7.1f8
Measurement Studio                  Visual Studio 2005 Support - See individual versions below.
NI-USI                              1.0.2
NI PXI Platform Services            2.5.6
NI-PAL Software                     2.5.4
NI LabVIEW SignalExpress            2.5.1
NI Spy                              2.7.2.49152
NI System Configuration             1.1.1f5
NI-VISA                             5.0
     NiVisaServer.exe               4.2.0.49153
     NIvisaic.exe                   5.0.0.49152
NI-VISA Runtime                     5.0
LabVIEW Run-Time 8.0.1              8.0.1
LabVIEW Run-Time 8.2.1              8.2.1
LabVIEW Run-Time 8.5.0              8.5.0
LabVIEW Run-Time 2009 SP1           9.0.1

0 Kudos
Message 9 of 10
(7,094 Views)

It looks like you need to get to get labview 8.6 or newer, or you need to get ni-visa 4.2, and ni-488.2 2.4

Jensen
National Instruments
Applications Engineer
0 Kudos
Message 10 of 10
(7,079 Views)