Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

LabView, 4156c, unable to configure SMU3 or 4

I don't see anything wrong with that code.  I assume you have tried resetting the instrument with the INIT vi, then assigning the SMU setups?  If that doesn't work, then try this..

 

hp415x_del_chan_setup.png

 

It's attached as a VI below and added to the debug example you posted.  Try that.

Download All
0 Kudos
Message 11 of 17
(117 Views)

Thank you for the response. Will it be possible to get the files that you attached in Labview 2018 format? My lab computer is old. It does not support 2019 or higher version. 

0 Kudos
Message 12 of 17
(114 Views)

Here you go, saved for 2017 so they will open for you in any newer version.

Let me know if they fix your problem.

 

Craig

Download All
0 Kudos
Message 13 of 17
(103 Views)

Looking through my version of the driver I see I fixed the SRES problem mentioned in the thread above, as well as the VAR1/naming issues.  I actually now use a modified version of the Agilent Configure SMU vi in my actual code. (Always good to read the comments!)  See...

 

hp415x_ConfigueSMU_FIXED.png

 

 

 

I've attached updated versions of your demo with my delete all channels, and configure SMU VIs in the zip file.  Attached in 2017 format.

 

Craig

0 Kudos
Message 14 of 17
(102 Views)

Thank you very very much, man. Thanks a lot. I dont know why all of a sudden this problem began in the first place though. Till last week the original config vis were working. And all of a sudden this started from this week. But anyhow, thank you very much.

0 Kudos
Message 15 of 17
(95 Views)

Also, only by deleting the channels before did not work as well. Only after fixing the SRES part, I guess it worked. 

0 Kudos
Message 16 of 17
(94 Views)

Hi cstorey,

 

I had posted a question in LABVIEW forum. But I was wondering whether you can help me out with this. 

 

I want to do a simple sampling measurement with HP 4156 and read the current (may be drain/source) with time. But whenever I run the attached program, it stops immediately or gives me an error with wait for acquisition. But when I do it manually, it runs perfectly. 

 

I have attached a file (sample_measure) which I wrote to do the simple sampling measurement. I have used the hp415x_configureSMU_fixed.vi which you fixed before when I couldn't configure the channel. 
Any help will be really appreciated. 

 

Thank you very much. 

0 Kudos
Message 17 of 17
(38 Views)