Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

Keysight DAQ970A not found by NI MAX

Hi RTSLVU,

 

The problem is the unit isn't seen by device manager after BenchVue, and all associated Keysight components have been removed.  This is also after LabVIEW has been completely uninstalled and re-installed twice.

LeahM_0-1616425196768.png

 

I asked a Keysight sales guy for help and he provided the Keysight helpline.  Posting his message for forum user's future reference:

 

"Call 800-829-4444 follow the prompt for product support and you will get a live person that is familiar with and also has a DAQ in front of them and can walk you through what you need to do."

 

Will let you know what I find out!🐯🐯🐯

 

0 Kudos
Message 11 of 21
(2,691 Views)

I will keep an eye on this thread... But I gather you are using the USB interface on the 34972A?

 

Try using the LXI interface (Ethernet), being LXI compatible Windows does not have to "see it" as long as NI-MAX can find it when searching the network for LXI devices you are good to go.

 

The problem I had with USB is the 34972A would just "disappear", (happened on several 34972A's and several computers) I am guessing it's related to Windows power management shutting of the USB ports. But I have never been able to find the proper setting to stop it from happening in Windows 7 though 10. So I abandoned using the USB port on those instruments years ago.

 

 

========================
=== Engineer Ambiguously ===
========================
0 Kudos
Message 12 of 21
(2,687 Views)

Yes - I'm using USB.  Would prefer to stick with USB, hasn't caused problems in the past.

 

OK - here's the result of the first pass with Keysight:

  1. Remove the VISA Shared Components:

LeahM_0-1616438214406.png

2. Select Yes to this prompt:

LeahM_1-1616438249110.png

3. and OK to this prompt:

LeahM_2-1616438322721.png

 

4. Go to this site and download the Keysight Libraries Suite driver

https://www.keysight.com/us/en/lib/software-detail/computer-software/io-libraries-suite-downloads-21...

 

5. Do a typical install.  Keysight IO Libraries should now show up in the programs list:

LeahM_3-1616438464146.png

 

The bad news I still get this with the DAQ970:

LeahM_4-1616438571108.png

 

The GOOD news is my 34972 VISA connection is working again!!!  BTW - the VISA components also came back (at a different revision):

LeahM_8-1616438922561.png

 

 

Keysight will follow-up with me to figure out the DAQ970 issue.  I'll post results here.

LeahM_5-1616438758932.png

 

 

 

0 Kudos
Message 13 of 21
(2,644 Views)

Sorry if this is a re-post, first post didn’t make it?...

Yes – we’re using the USB to communicate to the 34972A.  Always worked in the past!

 

Had a chance to discuss this with the Keysight folks.  Here is what we’ve done so far:

Uninstall the VISA Shared Components

LeahM_0-1616443214005.png

 

Proceed with the uninstallation when prompted (click YES):

LeahM_1-1616443214009.png

 

Download the Keysight IO Libraries Suite and install from this site (choose typical installation):

https://www.keysight.com/us/en/lib/software-detail/computer-software/io-libraries-suite-downloads-21...

IO Libraries now installed:

LeahM_2-1616443214011.png

 

VISA Shared Components also installed (with updated version):

LeahM_3-1616443214012.png

 

The DAQ970 still isn’t communicating – but at least the 34972 is now working!!!  Will update when I know more!🐯🐯🐯

0 Kudos
Message 14 of 21
(2,645 Views)

OK - I posted the results from my discussion with Keysight twice now and it's still not showing up.  Seems the system (or somebody) doesn't like what I'm posting or maybe I'm just posting too many pictures leading to a no-post.  So - long story short:

  1. Uninstall the VISA Shared Components
  2. Proceed with the uninstallation when prompted (click YES to continuing with uninstall)
  3. Download the Keysight IO Libraries Suite and install from this site (choose typical installation):

https://www.keysight.com/us/en/lib/software-detail/computer-software/io-libraries-suite-downloads-21...

 

The DAQ970 still isn’t communicating – but at least the 34972 is now working!!!

Message 15 of 21
(2,645 Views)

Posting for a friend:

 

Hi RTSLVU,

Yes – we’re using the USB to communicate to the 34972A.  Always worked in the past!

 

Had a chance to discuss this with the Keysight folks.  Here is what we’ve done so far:

Uninstall the VISA Shared Components

rimfire44_0-1616510652164.png

 

Proceed with the uninstallation when prompted (click YES):

rimfire44_1-1616510652171.png

 

Download the Keysight IO Libraries Suite and install from this site (choose typical installation):

https://www.keysight.com/us/en/lib/software-detail/computer-software/io-libraries-suite-downloads-21...

IO Libraries now installed:

rimfire44_2-1616510652175.png

 

VISA Shared Components also installed:

rimfire44_3-1616510652176.png

 

The DAQ970 still isn’t communicating – but at least the 34972 is now working!!!

Message 16 of 21
(2,647 Views)

Sorry for all the posting - it wasn't showing up until now!  Anyway - here's the way to make your DAQ970 not show up as "other device":

 

Go to the DAQ970 menu:  User settings>I/O>USB Settings>File Access

                                           Turn off File Access for now

 

As it was explained to me - "File Access" causes the DAQ to act like a smartphone, allowing you access to the DAQ's files.  The Keysight rep thinks there is a conflict with the local firewall or IT seciruty settings.  Once this was turned off the DQAQ970 magically appeared in Device Manager & NI MAX!

Message 17 of 21
(2,633 Views)

Thanks for reporting on your efforts...

 

I think I will use the LXI interface on the DAQ970A exclusively just like I do on the 34972A

 

USB just has too many little "issues" like this to be reliable.

========================
=== Engineer Ambiguously ===
========================
0 Kudos
Message 18 of 21
(2,630 Views)

Hi, 

 

my DAQ973A is also not avalable on NI MAX. But you can also use the USB ID string for the initialize.vi. 

You can found this string in the DAQ menu.  

 

Go to the DAQ970 menu:  User settings>I/O>USB Settings>File Access>Show USB ID 

 

Minipilot82_0-1620798603409.png

 

By Lutz 

0 Kudos
Message 19 of 21
(2,506 Views)

@Minipilot82 wrote:

Hi, 

 

my DAQ973A is also not avalable on NI MAX. But you can also use the USB ID string for the initialize.vi. 

You can found this string in the DAQ menu.  

 

Go to the DAQ970 menu:  User settings>I/O>USB Settings>File Access>Show USB ID 

 

Minipilot82_0-1620798603409.png

 

By Lutz 


Thank you Minipilot82 that is good to know. I just recently changed the setup to communicate over LAN instead of USB as I just don't trust the USB driver anymore. So far it is working without any issues but I will keep this in mind if I need to use the USB again at some point.

0 Kudos
Message 20 of 21
(2,501 Views)