Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

Keithley 2701 Filter VI

Hi All,

The Keithley 2701 Filter VI provided in the Labview Driver package doesn't seem to be working. Either that or I don't know how to get it to work. I've tried running the Filter.vi independently from the rest of my LabView program and it produces an error after the VISA write. It gives me the "Parameter Not Allowed" and "Command header" errors, whenever I select Moving or Repeating as my Filter. When the filter is off, everything works fine.

I've attached the ConfigureFilter.vi I'm using.

Any suggestions?

-Usman
0 Kudos
Message 1 of 4
(2,579 Views)
Hi

If you look into the vi you see that user data is used to select the correct mode
(VOLT:, etc)

If the measuring mode of your system is not VOLT the message is not correct.
But maybe other problems arise. The order of programming these istruments is not arbitrary.

Take a complete example and modify that carefully till you get what you want.

greetings from the Netherlands
Message 2 of 4
(2,578 Views)

Hello, 

 

Bit of an old thread, but I ran into the same problem with this library. 

 

The "Select filter type" (TCON) command in ke27xx Configure Filter.vi seems to be the cause. From the users manual, this command doesn't accept a channel list argument like the COUN or STAT functions. 

 

The solution for me was to delete the channel list from the TCON function. (the 7th input to the large concatenated string in cases 1 and 2) and the commands were accepted. 

 

Hope this helps, (six years after the fact... 🙂 

 

G. 

 

Message 3 of 4
(2,081 Views)

9 years later this thread just helped me too!!!

Thanks.

And thanks to Keithley for keeping their drivers up to date Smiley Frustrated

0 Kudos
Message 4 of 4
(1,882 Views)