Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

Keithley 2635 ID Query Failure

I have run Keithley 2600 Series Example"Config Source and Measure", and it gives out following error.


VISA Read in Keithley 2600>KE26XX Config Source &


Therefore, I have run "", and found out that the error comes from "The ID Query failed". I have tried out the solutions from similar topics, such as Try adding the suffix "\n" or ";" to your query.  "*IDN?\n" or "*IDN?;", but it does not work.


Any help or info is appreciated. I've attached a picture of the VI in question, and 2600 series driver.

Download All
0 Kudos
Message 1 of 5

Have you enabled the RS-232 on the instrument: Menu -> RS232 -> Enable?

Then are baud rate etc all matching?

Also need to make sure the RS232 cable is straight through. Pin 1 to Pin 1, Pin 2 to Pin 2 etc and not a cross over cable.

0 Kudos
Message 2 of 5

Hi cymrieg,


Thanks for your response. I have tried your suggestions and have tested Keithley 2635 with LabVIEW example ‘simple serial’ and it gives out response. However, I still got ID Query Failure.

0 Kudos
Message 3 of 5

Do you really need ID check to work?  It's usually just used to test communications, or distinguish one instrument from another if you don't have a list of GPIB addresses on the bus.  Mostly though, its not needed to perform measurements.


Your driver looks newer than the one I have,  (2021-09-24 vs. 2020-12-30), and the ID check in mine is different that the code you showed.  I attached a little code that shows the old and new way they tackle the problem.  Interesting that the response string you posted doesn't have a letter designation ("2635: vs. "2635B").  So your string passes the new test but fails the old one.  (Are you sure you are using this new driver code?)   

I suggest you examine the code in highlight execution and see when the error occurs.  If it with the ID query post the full string as text, not an image.


How old is your firmware and instrument? I'm surprised it doesn't have a letter in the string.  An updated firmware might fix your problem with ID and perhaps a few more as there are always minor bugs in the first release of the instruments that get fixes as time goes on.











0 Kudos
Message 4 of 5

Hello cstorey,


Thanks for your response. I do not need ID check to work, but if I delete Query instrument ID part, it will give others error "1073807339" in "Error".


My driver is 2009 version. Maybe I unzip the folders, so the date of the files become 2021-09-24. Also, I am using LabVIEW2014 version (14.0.1), but your file is 20.0 version, so I cannot read it.


The Keithley 2635 firmware is 1.4.2 old version, but Keithley 2635 is not mine, so I hope I won't make any changes on it.


0 Kudos
Message 5 of 5