Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

Keithley 2000 labview problem

That driver seems OK, I hope you did not try to install visa 3.2, I'm at 5.1 due to lv2011.

So which example program from that driver are you using?

greetings from the Netherlands
0 Kudos
Message 11 of 19
(1,961 Views)

No, we left VISA alone.  I think we are at version 4.?  We tried both read multiple and read single and got errors.

 

0 Kudos
Message 12 of 19
(1,959 Views)

One other thing.  I'm assuming I do not need a scan card in my Keithley 2000 to run this VI.  I don't have a scan card, so I hope that is correct.

0 Kudos
Message 13 of 19
(1,958 Views)

Hi

Let us start with the ID-query error.

Can you go into the Initialize vi and create a probe on the output of the read function.

Or create an indicator on the output of the read. Another possibility is to switch on the (debug) lamp and see where the error comes from.

greetings from the Netherlands
0 Kudos
Message 14 of 19
(1,954 Views)

Hi,

 

This might have been solved already but I had a similar issue with the Keithley 6517B where I kept getting the RS232 Break Detected error.

I found out that by removing the VISA Clear function in the Initialize SubVI, this error didn't come up anymore.  Hope this helps.

 

-Shin

 

0 Kudos
Message 15 of 19
(1,209 Views)

Here is a very basic VISA communication scheme.  If you feed the output of the VISA Serial Configure Port primitive into the VISA Resource Name input, then you should be able to send and receive data from the device.

*IDN?\n

 Enter the command above into the write buffer.  When activated, it should respond starting with, "Keithley..."

 

Help the Community (and future reviewers) by marking posts as follows:
If it helped - KUDOS
If it answers the issue - SOLUTION
0 Kudos
Message 16 of 19
(1,205 Views)

sir i am getting error 803 and 800 on my keithley 2000 multimeter on connecting rs-232 cable.my cable are straight,on taking reading 2 wire resistance,p-lease help regard this.

0 Kudos
Message 17 of 19
(1,025 Views)

1) First make sure your Keithley 2000 firmware is as up to date as possible.

2) Next search for the 803 and 800 errors in Keithley manual.  (This is a LabVIEW forum, not Keithley.)

3) Start a new thread, describe the code you use and the errors.

 

0 Kudos
Message 18 of 19
(1,018 Views)

I ran into this problem, and the default settings for the Keithley 2000's RS-232 port were different than the default settings for the LabVIEW driver package.  Go into the "Initialize" VI and check if the baud, flow control & termination character are the same as what's configured in the RS-232 menu on the Keithley 2000.  Otherwise, set them to the same values.

0 Kudos
Message 19 of 19
(631 Views)