Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

Keithley 2000 labview problem

I am using labview instrument for a Keithley 2000 multimeter (downloaded from - plug and play version).  I have LabView 8.0 and am using RS-232.  When I run the VI I get a "invalid character" error on the Keithley, followed a few seconds later by an RS-233 framing error, also on the Keithly.  Eventually the VI times out and gives me ERROR - 1073807339.  Both my Keithly and my COM ports are set to 9600 baud with Flow: NONE.  Can you help?


0 Kudos
Message 1 of 19

is the end character correctly specified, and do you have the correct cable, what about stopbits etc.

Also check on the instrument.

greetings from the Netherlands
0 Kudos
Message 2 of 19

Thanks for the ideas.  The Keithley only has settings of BAUD rate, FLOW control, and Terminator setting (CR, LF or LFCR).  The manual does say a null modem cable can't be used, so I'll check that. 

0 Kudos
Message 3 of 19

in case of doubt use 1 stopbit.

And do not use higher baudrates on a k2000 without handshake.

greetings from the Netherlands
0 Kudos
Message 4 of 19

In the Keithley manual I found that the interface uses 8 data bits, 1 stop bit and no parity, which is what I'm using.  Now the Keithley is giving me an "RS-232 Break detected" error.  I'm still checking my cable.

0 Kudos
Message 5 of 19

My cable seems to be straight through, so it should be OK.

0 Kudos
Message 6 of 19

There is a bad command in that driver.  I've dug it out a couple times but can't recall exactly where it is.  Easy to find though if you put a breakpoint in the write vi. when you hear the beep- track the call path to find the bad command.

"Should be" isn't "Is" -Jay
0 Kudos
Message 7 of 19

OK, thanks.  I'm not that Lab savvy so I'm not sure I can do this.  Perhaps I'll Goggle the issue and see if a corrected copy can be found somewhere.



0 Kudos
Message 8 of 19

which example are you using, I can check it next week.

greetings from the Netherlands
0 Kudos
Message 9 of 19

Hi Albert,


We have made some progress.  Based on some advice we found online, we made sure our connection with the multimeter and LabView was working.  We opened MAX and using the Basic I/O panel we were able to use simple commands (from the Keithley manual) to access the multimeter.  We were even able to read the voltage from the multimeter.  But when we tried the LabView driver we got errors, such as ID Query errors.


We are trying to use the driver for LabView 8.0 with VISA 3.2 that we found on the page:




0 Kudos
Message 10 of 19