Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

Genuine NI GPIB-USB-HS warning message

Highlighted

After upgrading to the newest NI Visa and 488 drivers, I suddenly started getting a warning message (attached) that says the cable is not a genuine NI product.

 

In addition, if I am communicating with an instrument, 53132 frequency counter, for example and the instrument times out, I can no longer communicate with the instrument unless I switch to local mode first.

 

Has anyone encountered these issues or can suggest a fix? Thanks!

Message 1 of 26
(8,244 Views)

Hi mihaisp,

 

As per the warning message, the "NI GPIB-USB-HS" interface you are using is not a genuine National Instruments product although it may physically appear to be. I recommend you contact your local sales representative to discuss the potential replacement of the device.

There has been no attempt to change software/code to disable or alter functionality of the non-genuine "NI GPIB-USB-HS", the only changes have been to provide this notification to users. However, as this is not a National Instruments device we can not guarantee the functionality of the hardware or that improvements made in software for NI hardware does not have an undesirable effect on this illegitimate device.

 

Best,

Jake Bartholomew

NI R&D - PSE

Message 2 of 26
(8,182 Views)

I bought an ostensibly NI made unit from ebay and it worked fine with the NI ver 14 driver. When I upgraded the driver to 15, I got this warning message.

The unit is an extremely well done clone in physical appearance ,even at the board level the vias,parts placement and traces are almost identical.

The easiest difference to see externally, between my actual NI unit and the aparent ebay clone, is the fact the knurled screws on the clone are bright nickel finish,while the original NI unit (that does not report warning on 15) has blackened screws. The clone unit aparently seems to use the NI ***** 488 chip that NI does oem to vendors. It would be interesting to know if this is a real NI part or a cloned chip.

0 Kudos
Message 3 of 26
(8,071 Views)

Hi TimHughes,

 

We cannot speak to the wether any aspect of a cloned device is genuine or not. If you require a legitimate device that will work with the 15.0 driver I would be happy to put you in contact with a sales representative!

 

Regards, 

 

Kevin

Applications Engineer 

National Instruments 

http://www.ni.com/support

0 Kudos
Message 4 of 26
(8,035 Views)

@TimHughes wrote:
The easiest difference to see externally, between my actual NI unit and the aparent ebay clone, is the fact the knurled screws on the clone are bright nickel finish,while the original NI unit (that does not report warning on 15) has blackened screws.

Unfortunatey even minor physical differences are not a reliable indicator whether the device is genuine. The GPIB-USB-HS has been around for many years, and minor variations exist between different revisions of genuine interfaces.

0 Kudos
Message 5 of 26
(7,962 Views)

I accidently purchased a National Instrumens (not Instruments) GPIB-USB-HS.  My laptop is showing the blue screen of death (luckily had time to back it up).

 

Never purchase one of these clones, period.

 

If you already own one never perform a hardware reset, software reset, and definitely never turn off your firewall.  I started to have communication difficulties after performing resets in MAX I turned my firewall off for 10 minutes trying to troubleshoot communication issues and that's when it became clear beyond a doubt the source was from the GPIB-USB-HS.  

 

https://forums.ni.com/t5/Instrument-Control-GPIB-Serial/GPIB-USB-HS-error-37051-37052-37053/m-p/3757...

0 Kudos
Message 6 of 26
(4,886 Views)

I purchased a GPIB-USB-HS directly from NI and am getting the same error message.

 

Application built w/ LabVIEW 2017

Running on LabVIEW Runtime Engine 17

NI-488.2 Runtime 17.6

Message 7 of 26
(4,701 Views)

Same error.  Purchased GPIB-USB-HS through official NI channels years ago and have never has issues until attempting to install and run on a new Windows 10 laptop.

0 Kudos
Message 8 of 26
(4,324 Views)

Nvm.  Pls ignore the comment above.  I discovered that some GPIB-USB-HS units in my lab came through an unauthorized channel via China and with a new unit all communication problems appear resolved.

Message 9 of 26
(4,320 Views)

Hi arpasker,

 

Sorry to hear that you are experiencing problems using your GPIB-USB-HS. I'd like to get you in contact with one of our technical supporters so that we can understand your use case, when the unit was purchased, and your current software environment. This will help us understand why you may be seeing an error indicating the unit is not genuine.

 

We tried to reach you by private message but did not hear back. If you're still having difficulties with the GPIB-USB-HS, please reach out to technical support via opening a service request at www.ni.com/support.

 

Best regards,

 

Tom D.
Product Support Engineer
National Instruments
0 Kudos
Message 10 of 26
(4,236 Views)