Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

GPIB showing in device manager but not in MAX


GPIB showing in device manager but not in MAX

I am posting this message so that if someone else has the same problem they have a better chance to fix it. We had a laptop which had NI GPIB-USB-HS. We tried reinstalling the drivers several times with no luck. The hardware detected in device manger but never showed up in MAX. The GPIB trouble shooting utility simply said that there was a problem with the software install. Finally we found that there was a driver from ICS that had been installed in the past on that computer and it left a file by the name GPIB-32.dll in the system32 folder of windows. The NI Installation wasn’t able to overwrite this file. We manually deleted this file (after stopping most NI processes in services.msc and closing MAX) and got it from another computer and replaced it. (I turned off system restore to do this. Not sure if it’s necessary) Opened MAX again and it detected!!!

Instead of looking for the file on another computer an uninstall followed by reinstall of the drivers after deleting that file should also do the trick.

NI needs to put something into their installation so that it overwrites this file or at least lets the user know that this file exists and wasn’t replaced. The only alternative solution I could think of about for this was to clean out the computer and reinstall windows! Would have worked Smiley Wink

Hope this helps someone out there. It took us almost two days to figure out!

Message 1 of 6

Re: GPIB showing in device manager but not in MAX



Thanks for the info and the solution! I'll try to relay this information to the appropriate people so that we can include this information somewhere.



Justin E
National Instruments R&D
0 Kudos
Message 2 of 6

Re: GPIB showing in device manager but not in MAX

Thanks for the info.  I think this is what is happening to my laptop and USB-GPIB-HS.  We have totally wiped out NI's software (cleaned with msiblast and msicuu and deleted all NI Registry and folders).  We didn't look to see what files were left with in the System32 file.  Also we wer getting the Software error from the NI-488.2 Troubleshooting Wizard and no indication from the installers that is a problem.  Initially our issue was caused by (I think) iTunes version 8 having the Bonjour Service's mDNS Responder running during the install of a LV Built Custom Installer that carried NI-488.2 2.6.  We got the error (see attached picture) "The NI mDNSResponder 1.0.0 installation failed with the following error: Internal Error 2753. nimdnsNSPTool.exe.MDNS01 Continue?"  We think was the cause of the original corruption.


After we uninstalled iTunes and the Bonjour service we were able to install with NO ERRORS. But MAX couldn't see the device (found by Device Manager alright). This was all after several "cleanings" as directed by NI. But we will check to delete the GPIB-32.dll after a clean uninstall.  The NI Installer should really overwrite this.


I will post if this is solved our issue.


0 Kudos
Message 3 of 6

Re: GPIB showing in device manager but not in MAX

Alternately you can try to install NI-488.2 2.6 again and then upgrade to teh version you would like. That should 'in theory' clear up the issue.



0 Kudos
Message 4 of 6

Re: GPIB showing in device manager but not in MAX

SOLVED IT!!  Had to delete the GPIB*.dlls from the system32. There were about 6 dlls that I had to delete.  I don't if they had been left behind during the original installer crash or not. But a uinstall/re-install (even with NI's cleanup information) didn't resolve the issue. I HAD to delete the Dlls manually after a complete clean up (registry folders,etc) after a normal uninstall.


0 Kudos
Message 5 of 6

Re: GPIB showing in device manager but not in MAX

You save my day.


I've installed the NI-488.2 GPIB Drivers packet 3.0.2 for Windows 7 64-bit. With the Measurement & Automation application I've could connect to the GPIB-PCI board and also to my instrument (an electric loads in my case). Then I've started the GPIB Troubleshooting Utility but the tests had failed.
So I've reinstalled the software, use an older version and an other board with the same result.
After one day with blood, sweat and tears I've read your post. And yes and GPIB-32.dll from an other company reside in the system32 folder.
Delete file, reinstall NI-488.2 GPIB Drivers packet, run GPIB Troubleshooting Utility, be happy.


And so I repeat Jojis statement three years later: "The NI Installer should really overwrite this."



0 Kudos
Message 6 of 6