Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

GPIB explorer setup with secondary ethernet port

I have GPIB explorer installed on a computer with two ethernet ports connected to two different networks. I have tried to set up GPIB ENET controllers on both networks but GPIB explorer sees only the box connected to the network on the primary ethernet port.

 

Is there any way to point NI 488 programs at a specific ethernet port? Each box has a static IP address so I'm not sure why this is not enough info to find the controller.

 

All help gratefully received.

 

Christina

0 Kudos
Message 1 of 7
(2,668 Views)

Hi ChristinaJ,

 

It seems like though your two GPIB controllers are on separate networks, they may still be on the same subnet. If both Ethernet devices and ports are set up on the same subnet, when NI-MAX/GPIB Explorer performs its default search, it will only search on the primary Ethernet port and will only locate the instrument attached to that port, rather than both instruments. Setting the ports up with different subnets lets MAX/GPIB Explorer know that it has multiple ports to look on and it will discover both devices. To make sure your GPIB/ENET devices are on different subnets, you'll need to change their static IP addresses.

 

here are a few link that should serve as good resources moving forward:

Using Multiple Ethernet Instruments with Multiple Ethernet Ports

GPIB ENET Manual: Determining Network Address

GPIB Hardware Guide: Ethernet Configuration <- shows how to set IP addresses to keep devices on different subnets

 

 

Quick note: On Mac or Linux, once the GPIB-ENET/100 has been added to your system, you will need to remove and add it again in order to change the configuration settings.

 

Daniella C.
Systems Engineer
National Instruments
0 Kudos
Message 2 of 7
(2,634 Views)

HI Daniella,

 

Thank you for your reply. I have since discovered that the problem is not network related (I'm not sure how it's possible for different networks to have the same subnet - but it's not my area), the problem is actually with the ENET/1000. It turns out that I can happily communicate with ENET/100s on both networks, but cannot communicate with ENET/1000s on either network. symptoms are as follows:

 

Searching the network for GPIB controllers does not show ENET/1000s.

I manually add the ip address (using gpib explorer and selecting enet/1000) and the message comes back that there is no such device (though I can access the configuration page through a browser).

I then tried to add manually again, but this time telling gpib explorer that the controller is an enet/100. The message comes back that this device is not an enet/100, which tells me that there is some kind of communication.

 

I am running on 64 bit Red-Hat with the latest ni4882 and firmware.

 

Now that the problem appears to be a different one I will re-post as a separate question a with more suitable title.

 

Thanks,

Christina

0 Kudos
Message 3 of 7
(2,576 Views)

SOLVED: Issue addressed in realease 15.1.1 of ni4882 for linux

0 Kudos
Message 4 of 7
(2,289 Views)

Partially addressed in realease 15.1.1 of ni4882 for linux

0 Kudos
Message 5 of 7
(2,278 Views)

@ChristinaJ wrote:

Partially addressed in realease 15.1.1 of ni4882 for linux


Can you elaborate on how this was partially resolved. Which issues are you still seeing?

 

 

0 Kudos
Message 6 of 7
(2,096 Views)

I am now able to setup ENET/1000s with gpibexplorer via the primary ethernet port. I still have the same problem with the secondary ethernet port though.

 

It would really help to know what sequence of events gpibexplorer goes through in order to add a new device. For instance, I know that it pings the device at some point in the process (this part of the process definitely works because when I once forgot to power the box, I got an error "device cannot be pinged") which I don't normally get.

 

Maybe I will post a separate question to try to find out this info.

0 Kudos
Message 7 of 7
(2,018 Views)