Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

GPIB 488.2 Accretech UF3000 prober "RECEIVE COMMAND FORMAT INVALID !!" communication error

Go to solution

I'm using a Teradyne Magnum2 tester with windows to control a the prober.  It worked until a service technician repaired the prober and had to re-install it's software.  That changed the GPIB address from 4 to 1, which we fixed, but now it gives the "RECEIVE COMMAND FORMAT INVALID !!" on the prober.  This is in response to the "B\r\n" Query, which is supposed to (and used to before the repair) get the prober ID. 

The log on the prober shows that it got the "B" command but it seems like the termination may not match the tester anymore. 

I compared and set the config settings to another prober which works (in hindsight, i should have taken pictures of this prober before the repair.)


I also tried changing the EOS from the NI default send EOI to terminate read on EOS with no luck.  I attached the NI Spy of the tester init, which has the "B" command and pictures of the prober menus and communication errors.


Thanks for any suggestions!


0 Kudos
Message 1 of 3

Sorry, my attachments didn't work the first time, so I tried again...

0 Kudos
Message 2 of 3
Accepted by topic author SteveMC

The technician who knows the probers better came back from his COVID quarantine today and figured out the problem:  there's a third menu where GPIB configuration was set to 'special' instead of 'standard.'  Why Accretech has that as the default is beyond me (or why the guy who did the repair didn't reload the test house's config floppy.)

0 Kudos
Message 3 of 3