Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

Finding problem in using PCI 6542 with examples of HSDIO

Hey guys,
 
I have newly installed PCI 6542. I used MAX to check it operation and it was working fine. When I tried to open an example like Dynamic Generation and Acquition Demo.vi, I was not able to execute the vi as an error popped up. It says HSDIO Close.vi which is subVI is not executeable. When i open Close.vi I see that there is a broken line in Get session reference.vi which is which connects Refnum and Reference session. The line error shows "This wire is connected to polymorphic terminal that cannot accept this datatype". Kindly help me in solving this issue so that i can learn how to use this pci card and will be helpful for my project.
I am Using Labview 8.2.1 on WinXP machine
 
Thanks & Regards,
Sailesh
0 Kudos
Message 1 of 12
(3,391 Views)
Sailesh,

What driver version do you have installed?  The latest release is 1.5.1 and can be downloaded from:

http://digital.ni.com/softlib.nsf/websearch/C8A716351C950EF686257299005125F9

Do you have the same problem with all of the examples?  How about one of the smaller examples such as "Dynamic Generation with Exported Clock"?
0 Kudos
Message 2 of 12
(3,383 Views)

Hey Ryan,

I received Version 1.4 from NI guys. I am getting same error with all the examples. Anyways I will check once with the new version driver and get back to you. Thanks for the help and link.

Regards,

Sailesh

0 Kudos
Message 3 of 12
(3,369 Views)

Hey Ryan,

From the link for the new version of PCI-6542 Instrument driver is giving an error "Operation Timed out " at 99% of the download.

Can u just look into the link and fix it? I have also requested NI for the CD. hope it reaches me soon. Is there any other link where i can  download the driver?

Regards,

Sailesh

 

 

0 Kudos
Message 4 of 12
(3,350 Views)
There is a copy available on the public ftp at:

ftp://ftp.ni.com/support/hsdigital/ni-hsdio

Its an anonymous login so your browser should be able to find it.

-Ryan
0 Kudos
Message 5 of 12
(3,345 Views)

I'm having the same issue with a 5421 PCI Arb Gen.  The vi I wrote works fine on my desktop running LabView 7.1, but when I take it to the lab where we're running 8.2.1 I get the same error described by Sailesh, in my case with the niFgen Close.vi.  So it seems to be something related to with LabView, and not the arb drivers.  I have contacted the local NI rep but that could take a while, any direction of what I need to update/install would be most useful.

Mark Brueggemann
Albuquerque, NM

 

0 Kudos
Message 6 of 12
(3,322 Views)
This might be caused by different versions of the Unregister Session VI in LabVIEW 8.2.1 and previous versions (just a guess).  Mass compiling as part of the 8.2.1 patch install process may prevent this problem.  For now, please try deleting the broken wire and recreating it.
 
To better understand what might be causing this problem, please attach a list of all of the NI software and versions that you have installed.  You may be able to easily export this list from NI-MAX.
0 Kudos
Message 7 of 12
(3,307 Views)
Tried deleting and recreating the wire, that didn't fix it.  Attached is the report file, along with a screenshot of the affected VI.
 
Mark Brueggemann
Albuquerque, NM
0 Kudos
Message 8 of 12
(3,299 Views)
At least, I thought I had attached some files.  The forum police doesn't like the .html extension on the report file.   Let's try again...
0 Kudos
Message 9 of 12
(3,297 Views)
Hello, we think that your nifgen installation may not be complete.  Did you install nifgen before or after installing LabVIEW?  nifgen needs to be installed after LabVIEW to ensure that all support files are installed properly. Please try to run the nifgen installer again and let me know if this helps.
0 Kudos
Message 10 of 12
(3,278 Views)