Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

Error Connecting DPO7354 via VXI-11 LAN: 1073807346

Solved!
Go to solution

Hello,

 

I am new to Labview but experienced with computers, Python, C++, and other languages. 

 

I have been able to setup and detect my DPO7354 Oscilloscope thru VXI-11. I can successfully ping from both cmd prompts, write commands, query, and use the read command. But when I try to run the Tektronix 7000 Series Acquire Waveform.vi, I get the following errors:

 

Error -1073807346 occurred at VISA Open in Tektronix 7000 Series.lvlib:Initialize.vi->Tektronix 7000 Series Acquire Waveform.vi

Possible reason(s):

VISA: (Hex 0xBFFF000E) The given session or object reference is invalid.

 

I have googled this extensively. I have done the following: 

- Open all ports + disable Win firewall

- Set read from binary to hex so that I'm not bit limited (was stopping read on VISA Test Panel) 

 

But I still also get errors reading from the test panel: 

Read Operation
Error

VISA: (Hex 0xBFFF0015) Timeout expired before operation completed.

 

It works fine after query but after I read through all the query data it reads that error. I can adjust the bitrate to make it through that data but that's it. 

 

Any ideas? It would help me troubleshoot this a lot if I knew it was a problem with connections, ports, data, my labView config, my .vi config, etc...

 

Thanks a ton 

0 Kudos
Message 1 of 6
(504 Views)

Hello again,

 

thanks for checking in. I'm attaching some pictures 

labviewproblem1.pnglabviewproblem2.pnglabviewproblem3.png

0 Kudos
Message 2 of 6
(469 Views)

Hi

Did you fill in the exact same resource name in the example vi as in the visa session?

Resource name not valid suggests this.

greetings from the Netherlands
Message 3 of 6
(452 Views)

Hello and thanks for the help, 

 

yes it was also labeled "inst0" in the vi editor

 

NI support thinks it couldve been an issue not using the right name, as in it has to have certain parameters

 

We will see tomo

0 Kudos
Message 4 of 6
(448 Views)

Hello and sorry to bump my own post,

 

I am closer and closer to a solution.

 

I have isolated it to LabView not recognizing my VISA Resource Name. 

 

Has anyone had any similar issues and can offer a solution?

 

I have tried all types of names, examples:

 

TCPIP0::TEKSCOPE-DPO7354::inst0::INSTR

TCPIP0::IP_ADDRESS::inst0::INSTR

 

and everything in between and all kinds of variations.

 

Thanks

0 Kudos
Message 5 of 6
(427 Views)
Solution
Accepted by topic author chemengstudent

If anyone else ever has the problem:

 

Disable Tektronix VISA in Conflict manager. 

 
0 Kudos
Message 6 of 6
(382 Views)