Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

Error 1386 with ThorLabs camera

I've been trying to use LabView 20.0.1 to control a ThorLab CS235CU camera. I pulled a VI and its supporting DLLs from ThorLab's program files, but after putting the DLLs in the proper folder and making sure everything was 64-bit, I keep getting error 1386 (screenshot below). I tried running labview as an administrator and tried creating the labview.exe.config text file recommended here. However, both these solutions didn't stop the error from occuring. The error occurs at step 2 (TLCameraSDK) through 4 when running with highlighted execution. I unfortunately cannot attach the DLLs to this post, as their zip is too large, but I've attached one of the thorlabs-provided VIs that I've been having trouble with.1386 error.PNGerror message.PNG

0 Kudos
Message 1 of 4
(1,114 Views)

tomcolburn,

 

Did you ever find a solution to this error?  I am experiencing the very same issue and I'm hoping you found a solution.

0 Kudos
Message 2 of 4
(627 Views)

I got it to work by entering the path to the library manually see screenshot

MaBaas_0-1688042662297.png

 

0 Kudos
Message 3 of 4
(575 Views)

I'm adding this in case others find a similar problem in the future. I had the same 1386 error attempting to use LabView 2023 64 bit to connect to a Thorlabs Zelux camera. I tried all the suggestions here and they didn't work. However, what did work was to make a different configuration file, the one suggested here. After this I was able to open and use the camera.

0 Kudos
Message 4 of 4
(358 Views)