Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

Error -1073807346 randomly showing up only in specific VI

Hi to Everyone,


i am currently working on an internship project and have come to a point were I have to integrate a "MCC-1" programmable dual axis stepper motor controller from Phytron into an existing LabVIEW application in order to move a stepper motor. I was setting the system up to get it to run with the already exisiting program by simply using the Phytron LabIEW VI's for the controller which were included in delivery. I've already been able both to communicate and move my stepper motor with every single VI's which was delivered. Everything worked fine.

Until out of all sudden random "Error -1073807346: Given Session or Object Reference Invalid" errors started to show up when I was trying to use the so called "Directmode" VI which let's you send commands to the motor itself by using VISA write and VISA read functions (i.e. move 5000 steps in positive direction). It's behaving like no Controller was connected to the specified COM-Port.


I am connecting the controller via an USB-A/B series connector directly with an USB input of my computer.

The COM shows up both in LabVIEW and NI MAX as I expected it would. Also in Windows.

What's confusing to me is that other VI's which were included in the delivery actually still work with the same controller (for instance the Counter VI which is not giving out a write comment but only read commands) and with the same COM-Port. The only VI not working is the "Directmode" VI which is attached below when I am using it "directly".


Please note that I've been connecting a whole lot of other instruments to my Labview program via RS232 (among others). For this I am using third party Serial to USB Adapters which are made for USB 2.0 although I am only having USB 3.0 USB ports available on my computer. Might this have anything to do with "too much traffic" going on?


As I have somewhat of a profound knowledge about and experience with LabVIEW from my studies myself I was trying to figure out the problem myself, but as this seems to be a VISA problem of bigger scale and I've been trying to fix this problem for more than 3 days without no success I am really getting frustrated.

I tried changing the VISA read and write functions from Asynchronous and synchronous and vice versa. I searched the internet everywhere but nobody seems to have experienced this particular error behavior.


I have uploaded the occuring error messages from the broken VI and the VI itself.

The VI's can also be found on the manufacturers website:


I am kindly asking for help for this problem.





0 Kudos
Message 1 of 2

In the following post there is a suggested solution

Could it be useful for you?

0 Kudos
Message 2 of 2