Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

Entry point Error in gpib-32.dll

Go to solution

When I try to open VISA Interactive Control in NI MAX but it give me an error  saying "Procedure Entry Point xxxxxx could not be located in Dynamic Link Library C\....." (see attachment)

and probably because of this i am not able to communicate with GPIB connected intruments in LabView even though the instruments are shown in VISA resources List in LabView.


I have also attached a picture of error that i get in LabView when i try to run a program.


Please help 


Thank you

Download All
0 Kudos
Message 1 of 6


If this error is related to this post, it is likely that the old KPCI-488A driver caused an inconsistency in the NI driver.
Please remove the KPCI-488A driver and reinstall the NI software. (As I wrote in another post, KPCI-488A is old, so it is recommended to use USB or LAN instead of GPIB)

0 Kudos
Message 2 of 6

Hello, thank you for your response. Yes it is related. 

I would like to state that I have been working the same driver and same set of instrument for past two years and everything (two lockin amps, one keithley multimeter along with Agilent LCR meter) was responding fine.

The other day I connected a Tektronix Function generator via USB and ran a VI which also included my Keithley multimeter. It ran fine.


But now the other GPIB instruments are not communicating even though they are listed in the visa resources.

(idk if it is related to connecting the Tektronix FG)


Also, i noticed noticed that the in gpib-32.dll file's propeties>details, the entry for copyright is empty..!!

Do you think it is related ? !! 

0 Kudos
Message 3 of 6

@kharkhua さんは書きました:


Also, i noticed noticed that the in gpib-32.dll file's propeties>details, the entry for copyright is empty..!!

Do you think it is related ? !! 

NI-488.2 compatible drivers have a method of replacing NI driver files, so I think this is the effect. If it is a genuine NI driver, the copyright column of the DLL will have a display of National Instruments. (Because it is a modern DLL, it also has a digital signature, which is a proof of authenticity.)

0 Kudos
Message 4 of 6

I visited the link that you had shared earlier


There are points mentioned about testing the KCPI 488 itslef. I followed those steps.


The GPIB driver seems to have some problem. When I run GPIB Diagnostic, it gives the entry point error. I tried re installing GPIB 488 driver but did not work.


Thanks anyway

0 Kudos
Message 5 of 6
Accepted by topic author kharkhua

I deleted the gpib-32.dll file from National Instruments from system32. After installing Keithley GPIB 488 9.2 driver, the problem is gone. 

I uninstalled NI GPIB driver and deleted dll file related to it. 

Installed Keithley GPIB driver. Checked with GPIB diagnostic. Keithley card responds.

Installed NI VISA (without NI 488) and Labview. Now everything is fine

0 Kudos
Message 6 of 6