Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

Batch file to restore Tulip in visa 19.0 doesn't run

Solved!
Go to solution

Hi all,

 

Updated to Visa 19.0 and NI-MAX visa option doesn't have option to activate Tulip.

Found the link below and tried but it didn't work.

 

https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z0000015CnsSAE&l=en-AU

 

The error message is shown below.

 

Capture.PNG

Can anybody help me with this?

Thanks.

 

0 Kudos
Message 1 of 11
(463 Views)

What version windows do you have and do you have admin rights on that particular computer?



0 Kudos
Message 2 of 11
(372 Views)

It is Windows 10 version 1803.

Yes, I have admin rights. Thanks.

0 Kudos
Message 3 of 11
(359 Views)

Also copying error message in command window hoping it can be a help.

Capture 2.PNG

0 Kudos
Message 4 of 11
(348 Views)

Ok, this might just be me being dumb because it's been quite a while since I've done command line stuff but the file I ran was a .bat . It also worked perfectly. The first error you posted was stating that the installation file could not be opened, leading me to believe that the extension was wrong.

 

Additionally, no where in the second image do I see "RestoreTulipPassport.bat "

 

Am I missing something?



0 Kudos
Message 5 of 11
(325 Views)

Yes, I also ran bat file 'RestoreTulipPassport.bat' which pops up this cmd screen with error message.

0 Kudos
Message 6 of 11
(307 Views)

So basically when I run bat file, it pops up two windows. One is the cmd window and the other is the Windows pop-up dialog with error message.

0 Kudos
Message 7 of 11
(302 Views)

Perhaps give up on the batch file and try installing NI-VISA again with the offline installer that you can get on NI website?

OfflineInstallVISA.png

0 Kudos
Message 8 of 11
(297 Views)

I was able to duplicate your error midam7 ! Granted... on a Windows 7 Machine, but still. I duplicated both your cmd window and the Windows pop-up dialog.

 

When you go into NI Max -> Tools -> NI-Visa -> Visa Options, is the Tulip passport still missing or is it visible?



0 Kudos
Message 9 of 11
(275 Views)

Tulip passport is missing - see screen shot belowvisa option.PNG.

0 Kudos
Message 10 of 11
(249 Views)