Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

Agilent usb-GPIB 82357B is not shown in NI MAX

I am trying to communicate with a spectrum analyzer through a Agilent USB-GPIB (82357B)

Only the USB head of cable is connected to my USB port of my computer and I am trying to check if NI MAX can recognize it or not, I have checked the tulip.dll in my passPort and restarted my PC in order to be able to communicate with Agilent GPIB, but no connector is recognized in NI MAx, and it is unknown in VISA interactive Control as well, as it is seen an attached files. I appreciate any suggestion and help if any body can tell me why it can not recognize my GPIB cable? 
Thanks.

Download All
0 Kudos
Message 1 of 5
(6,502 Views)

Hey Vima, 

 

Have you checked out Using Keysight (HP Agilent) 82357A/82357B GPIB in Measurement & Automation Explorer (MAX) or LabVIEW

 

There's also information on Keysights website at: http://literature.cdn.keysight.com/litweb/pdf/5990-3731EN.pdf

 

If you follow the instructions in these for using the device in MAX do you see any change?

 

Let us know how you get on.

Henry

Message 2 of 5
(6,315 Views)

Hi everyone,

 

faced the same issue today (after migrating to Win10).

Any ideas how to solve it? Getting tired of reinstalling and rebooting

CLD
NI WorldClass 2015
0 Kudos
Message 3 of 5
(5,878 Views)

You probably need the latest Keysight I/O libraries for Win10.  Have you installed those?

 

Also look at installing side-by-side VISA - https://www.keysight.com/main/editorial.jspx?cc=CA&lc=eng&ckey=2034764&id=2034764&cmpid=zzfindside-b...

0 Kudos
Message 4 of 5
(5,869 Views)

Download latest keysight I/O libraries and check 82357B connection status there. Go to Settings>488 programs>check  'Enable Keysight GPIB cards for 488 programs ' .

hope it will help you.

Thank You

0 Kudos
Message 5 of 5
(4,698 Views)