Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

Agilent InfiniiVision MSO-X 3024A 200MHz

Agilent InfiniiVision MSO-X 3024A 200MHz

Hi All 


I am using Agilent Technoligies MSO-X 3024A oscilloscope to connect it via USB to LabVIEW. I have installed the driver, found through Labview help. 


When I run example vi's of the driver for instance "Series Acquire Waveform", it put my oscilloscope in default settings (a message appears on the oscilliscope) and then hangs it (osc). 

There is no output/waveform on the vi front panel. It would also hang the vi as it would take a while to stop the simulation. Then I would have to restart the oscilloscope to make it functional. 


I have tried Driver Revision: 1.0.1 and 1.0.2, but same problem. 

I tried making my own vi, but same problem. 

I tried reading the status from Measurement & Automation, it reads back the device id that matches the device id on the oscilloscope.


Any ideas that I can put to test? 

Your reply will be very much Appreciated. 



0 Kudos
Message 1 of 2

Re: Agilent InfiniiVision MSO-X 3024A 200MHz



Looks like I have solved this issue. It turns out that Agilent conenction expert needed to be installed, which then installed another IVI C driver. *phew*

0 Kudos
Message 2 of 2