Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

34465A Freezes on Error Code

I have the EXACT same issue going on right now.  I tried your method in "Error", but for some reason the problem seemed to appear in other locations where a write followed by a read would occur.  I'm using LabVIEW 2018 on a W10 x64 machine. 


Something that I did that worked for me thus far is shown below, also in "Error".  This is using LabVIEW 2018's "Stall Data.vim" function.  You could do it with a simple "wait" function too.


After some poking and prodding, I found that the first time this is called... in the "Initialize" routine where it's reset, etc... a delay of half a second seems to allow the DMM to have time to respond.  After the first time it's called... it seems to work even without a delay.  (Your mileage may vary).  


Sometimes, I was seeing it freeze between "CLR" and "STB" as well, so I added a half second delay there too for good measure.  Haven't seen yet whether this makes a difference.





Message 11 of 15

Good fix. I've noticed that the updated HP, then Agilent and now Keysight Technologies instruments seem to have much more verbose error messages.  Its caused problems in the of otherwise fully functional LabVIEW instrument drivers.  Not sure if that's part of the issue here.  If the call to :SYST:ERR? takes longer for the instrument to format its response, then a delay is a good fix. 


Now to be safe I'd increasing that buffer size of the read bytes limit to more than 256, say 1024 or 2048.  Its really just a memory buffer maximum, so 10,000 isn't going to hurt performance and would be safe for large multi-line errors.  But no one ever makes those right? 😉  

0 Kudos
Message 12 of 15

Thanks for your investigations 





0 Kudos
Message 13 of 15

Thanks for the post. I encounter the same problem. Both of keysight 34465A and VI freeze when I run VI. Pull out the USB connection can release the freeze of VI. But keysight 34465A needs power off and on. I spend 2 days to find the solution. Below is the answer.

Just install "Keysight IO Libraries Suite" and everything will be find.

It's Keysight's VISA but I don't actually know how it fix the problem. 

Below is the help document from keysight during installation process. Maybe some expert can teach me why this solve the problem and how it cause the freeze. Anyway, install the Keysight's VISA solve the problem. Hope anyone encounter the problem can see this post earlier.


Install Keysight VISA

This dialog box allows you to install Keysight 32-bit VISA as the primary or secondary VISA implementation (VISA (Virtual Instrument Software Architecture) is an industry-standard I/O API. It can be used to develop I/O applications and instrument drivers that are interoperable with many other VISA applications from many vendors, and that comply with IVI Foundation standards. what is VISA?).

  • Select Install Keysight VISA as primary VISA when Keysight VISA will be the only 32-bit VISA installed on this PC.
  • Select Install Keysight VISA as secondary in side-by-side mode when you intend to use Keysight VISA and a non-Keysight VISA, such as NI VISA, on the same PC.

Primary and Secondary 32-Bit VISA

The 32-bit versions of  VISA are NOT automatically managed*. When using Keysight VISA together with another vendor's VISA on the same PC, one VISA implementation is designated as primary, and the other is designated as secondary. This primary/secondary designation is known as side-by-side mode. In side-by-side mode, Keysight VISA is installed in a secondary location and does not overwrite the other vendor's VISA (the primary VISA).


In general, 32-bit non-Keysight VISA implementations do not support being operated as the secondary VISA. This means that you must operate Keysight 32-bit VISA as the secondary VISA, and the other vendor's VISA as primary. Following installation of the Keysight IO Libraries Suite, you can find more details on side-by-side mode in the Keysight IO Libraries Suite help. You can view this help by clicking Documentation > IO Libraries Suite Help from the IO Control (click at the bottom right of your screen).

*When installing on a 64-bit operating system, the Keysight IO Libraries Suite installer installs a 32-bit and a 64-bit version of Keysight VISA. When installing on a 32-bit operating system, the Keysight IO Libraries Suite installer installs only a 32-bit version of Keysight VISA. The 64-bit versions of VISA are automatically managed, so no primary/secondary designation is needed for the 64-bit versions


Message 14 of 15

Thank you for the suggestion!!

I had almost the same issue with Agilent B2902A SMU (older revision). After the device is first time plugged to PC via USB, LabVIEW execution freeze on error query read, until the device is unplugged. Workaround was to open error query VI and for the first run after plugging in, run it with Highlight execution enabled, then all other calls can be done as usual. I thought it was some delay problem, but adding a few seconds delay between each VI part didn't help. Also, there was no such issue when using GPIB. But after installing Keysight IO Libraries Suite all is working smoothly, without changing anything in the code. Adding a comment so someone googling issues with SMU could find this thread about DMM. 

0 Kudos
Message 15 of 15