Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Did you mean: 

2 wire RS485 communication PXIe-8431/16 does not work

Go to solution

Hi all,


I am trying to communicate with a custom build pcb and a port of a PXIe-8431/16 via 2 wire RS485 Modbus. I use Measurement and Automation Explorer 17.5.0f0 and NI-Serial 17.0. The PXIe card is installed in a PXIe-1065 rack. The rack communicates with the PC via a PXIe-8370 card. In both Max and Windows device manager I can see all the serial port devices for the serial card. The connection between the PXI card and the PCB runs via a SH68-8DB9 RS485 197546C-01 cable.


I am trying to do Modbus communication over 2-wire RS485 to a custom build PCB. When I use an FTDI USB to RS485 adapter, communication is successfull. I can't get it to work with the PXI card  though.


I found in this topic I have to short pins 4 and 8 and pins 5 and 9 on the DB9 connector to use 2-wire communication. Over here I found that I have to set the Transceiver mode to "2 wire auto" since I don't use the DTR specifically. I also tried the other modes without any luck. I set these mode via Windows device manager since it is grayed out in Max.


If I hook up the transmit lines of a PXI port to the receive lines of another PXI port, I receive the data on the second port that I send through the first port. This works when I set both transceiver modes to "4 wire" or when I set both to "2 wire auto".


When i connect only the the transmit lines of a PXI port to the custom PCB, i see the RX and TX LED getting active. I checked with a scope with serial decoder and the PCB produces the correct Modbus answer. It isn't received by the PXI card however since the receive  lines are not connected in this scenario.


When I make the 4-8 and 5-9 bridges on the DB9 connector, the PCB doesn't receive anything. When I decouple the PCB, the bridges work as a loopback when I check with Max VISA test panel in 4-wire mode. In 2-wire auto mode, the error "VISA: (Hex 0xBFFF003E) Could not perform operation because of I/O error" pops up.


On the PCB I have an optional 120R resistor as bus terminator, switching on or off the terminator hasn't got any effect.


Who can think of something else to check?

0 Kudos
Message 1 of 3
Accepted by svh

Does this only happen to me? After typing my whole story, I tried another 68pin to DB9 cable and now it works.



0 Kudos
Message 2 of 3



You have a FTDI RS-485 interface working. If you connect this interface to the PXI RS-485 network you can see the data.

Some manufacturers switch the A(+) and B (-) connection, but never seen this with NI or FTDI devices.

Another stupid question: sure about the settings speed, parity, 8 bits ?



0 Kudos
Message 3 of 3