InsightCM

cancel
Showing results for 
Search instead for 
Did you mean: 

Adding a bandpass filter to a signal on InsightCM

Hi all,

 

I have an InsightCM server where I monitor the data from velomitors mounted on flanges of a turbine.  The machine protection system I use takes the velomitor signal and applies a bandpass filter from 40-300 Hz in order to filter out noise.  The signal is then integrated so that I can see vibration data in mils.  As such, I need to mimic this filter and integration on InsightCM.  When I configure my velocity assets, I'm given the option of a low frequency cutoff which I set to 40 Hz.  I then hit the single integration button and apply a single integration cutoff of 40 Hz.  Even after I do this, the data on InsightCM does not match up with the data from my machine protection system, which I know is correct.  I believe I need to add an additional low pass filter at 300 Hz (essentially a bandpass from 40-300 Hz) to make the data match, but I don't see an option for this on InsightCM and I'm not sure how to proceed.  Any help you can provide is much appreciated.

0 Kudos
Message 1 of 4
(101 Views)

We don't currently have a specific user-defined low pass filter, although the acquisition hardware does filter high frequency data, based on the sample rate.  You could set the sample rate at 1024 to effectively achieve a 400Hz lowpass filter on the data.  This would make your Fmax 400 as well.

 

There are other factors that could make the data appear different in Insight than other systems.  Any differences in sample rate between the two systems will affect the data.  Fmax and LOR also will obviously make a big difference if you are looking at the spectral data.

0 Kudos
Message 2 of 4
(68 Views)
Highlighted

Thanks for the quick response!  I tried setting the sampling rate to 1024 but the data is still very off.  To give you an idea, for one flange I'm expecting vibrations of about 0.2 mils pk-pk, and InsightCM is showing me that the vibration is about 5 mils pk-pk.  Before I set the low frequency cutoff to 40 Hz, that number was way bigger which is why I got the idea to set a high frequency cutoff at 300 Hz.  Based on your answer, are you saying that there is no way for me to filter the signal in the way I want? In other words, it seems unlikely that I'll be able to get the data to match (assuming that this is where the problem stems from)?

0 Kudos
Message 3 of 4
(53 Views)

You are correct that currently in InsightCM, you won't be able to set the exact band pass filter settings that you are after.

 

A couple things on trying to match the data.  You may want to be sure that the sensor sensitivity is set correctly, and that the sample rates and block sizes match (if possible).

 

Do you have any way to compare the velocity data (prior to integration)?  That would help a lot in determining why the data is different.

0 Kudos
Message 4 of 4
(25 Views)