Industrial Communications

cancel
Showing results for 
Search instead for 
Did you mean: 

XNET 9862 short?

Highlighted

I have an NI XNET 9862 in an NI DAQ 9171 chassis.

I've used the CAN device before, so I know it worked in the past.

I'm trying to use it again, but when I connect pin 9 to power +, and 3 & 6 to power - the power supply goes from 12.5 V to about 0.3 V and the CAN device does not work.

The message from Bus Monitor is that the device does not have power (you are trying to start an interface that is missing bus power for the transceiver..., BFF63028).

I've tested my DB9 connected without the 9862 connected, and there is the correct power to the pins, I verified with a dmm.

 

I got info to confirm what I'm doing here:

https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000fxwGSAQ&l=en-US

 

Any thoughts, or is there an internal problem?

 

0 Kudos
Message 1 of 4
(71 Views)
Highlighted

try connecting pin 6 alone or try increasing your input voltage to 24V DC

0 Kudos
Message 2 of 4
(45 Views)

Thanks for the tip. I already tried each individual COM pin with power to pin 9. No luck.

I tried different voltages at pin 9, also no luck.

I was able to get another XNET 9862, and this works in the exact same set up. 

So, I guess the other one has something wrong inside that it is not getting power to the transceiver. I'll have to investigate after I'm back in the office.

0 Kudos
Message 3 of 4
(40 Views)
Highlighted

Good, try resetting the module from NI MAX just to see if there is any odd behavior due to firmware. 

0 Kudos
Message 4 of 4
(21 Views)