Industrial Communications

cancel
Showing results for 
Search instead for 
Did you mean: 

Time synchronisation: NTP vs. IEC 60870

Solved!
Go to solution
Highlighted

Hi,

I'm using IEC 60870-5-101 with the toolbox available from NI on a cRIO 9063. Previously we operated on a VXWorks based cRIO and migrated recently to RT Linux and LV 2017. After the migration, we are facing issues with the NTP time synchronisation. It seems that the IEC module accesses the system timer and collides with the NTP, which we installed via the package manager.

 

In VXWorks, there was a section in the ni-rt.ini, where sources and priorities for time synch could be configured. But I am not aware of a comparable file in RT-Linux. Maybe it's possible to manipulate access rights for the HW timer devicefile so that the IEC module is not able to interfere anymore? Or are there config files for the module?

 

I'm looking for a solution that does not require recompilation of the LV code since I am working on a remote target. putty access is available.

 

Thanks!

0 Kudos
Message 1 of 4
(181 Views)

Is this article helpful for you?

Installing and Configuring NTP on NI Linux Real-Time Devices

Emboar
Certified LabVIEW Developer
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
0 Kudos
Message 2 of 4
(152 Views)

Thanks! I didn't know this page, but it seems this is how we installed the ntp service.

 

Found something here, where it says there should be a way to configure different time sources.

 

But in MAX on my system, the elements for configuring different time sources stay blank. Thought I might need to install "NI-Time-Synch Time Reference for IEEE1588", but that did not help.

 

Via top on linux console I found a process called /usr/local/natinst/share/TimeSync/nitsmd
Found some .json files there, e.g. tsm.json:

{
   "timeReferences": {
      "I870_1": {
         "priority": "unknown",
         "defaults": "/usr/local/natinst/share/TimeSync/TimeReferences/I870.json"
      }
   },
   "timeKeeper": {
      "library": "/usr/local/natinst/share/TimeSync/TimeKeepers/liblinuxTimekeeper.so.17.1.0"
   },
   "servo": {
      "library": "/usr/local/natinst/share/TimeSync/Servos/libdefaultServo.so.17.1.0"
   },
   "disabled": {}
}

But no ntp here. So how to proceed?

0 Kudos
Message 3 of 4
(135 Views)
Solution
Accepted by topic author SKauth

It seems this works as a workaround:

mv /usr/local/natinst/share/TimeSync/TimeReferences/libts_i870.so /usr/local/natinst/share/TimeSync/TimeReferences/libts_i870.so.BAK
0 Kudos
Message 4 of 4
(97 Views)