Industrial Communications

Showing results for 
Search instead for 
Did you mean: 

Profibus VI will not run due to missing Vi's

My PCI profibus card (780160-01) was running with LabView 2011on a  Xp machine. I changed the PC to Win 7 and reinstalled the software and drivers, including NI-Visa 4.6. Looking at Comsofts Configurator II everything seems OK. 

My problem is the DF Profi II - ProfibusExample.lib was not added to the add-ons. I think all I need is the Comsoft.lib or the ProfibusExample.lib and a location to put it?



0 Kudos
Message 1 of 13

Hi Newbe,


You may just need a driver update for which can be found here. Please try this and let us know if it works!

Josh Y.
Applications Engineer
National Instruments
0 Kudos
Message 2 of 13


I've got the same Problem! Did you solve it? I tried the new driver but nothing changes?


0 Kudos
Message 3 of 13

Hi Joachim,


What behavior are you seeing? Did you also start seeing this after upgrading your OS from XP to 7? When you say you tried the new driver, was it NI PROFIBUS 1.3 or did you also download other drivers such as NI VISA?

Josh Y.
Applications Engineer
National Instruments
0 Kudos
Message 4 of 13

Hi! I have Win7 in use and evaluation of labview 2012. Somehow the installation is not able to install the VIs in the folders. After placing the VIs manually in the correct folders the filepath of DF PROFI II-Firmware has the wrong link. But the VI is protected.



0 Kudos
Message 5 of 13

The following worked in my situation;

- Uninstalled Comsoft Configurator II, Network config and Profibus VISA driver 

- Installed NI VISA 4.6 driver

- Re-installed Comsoft DF_Profi_II_LV_1.37.1





0 Kudos
Message 6 of 13

I have similar problem. The Configurator does not show anything as described in the help menu for Profibus starter. It does not show the save button either. I have reinstalled everything as described here but no use. I hate this junky product that are not well documented and keep you hanging there with no support! help wanted!!!

0 Kudos
Message 7 of 13



What hardware, driver versions and Configurator versions are you using? 


The save button only shows once you have created a project that can be saved. It doesn't show when there is a blank project. 




Jesse Dennis
0 Kudos
Message 8 of 13


I have PCI PROFIBUS (780160-01) with the latest software as described above by (Newbedan). We got these boards two years ago, but recently started using them. As described above, it was a very very long learning curve when the provided CD software does not do what is supposed to do and for my questions from NI I must get to forums!! All of our testing platforms are NI based, NI can do better job to keep their customers happy!


Using Configurator help that does not match configurator view, FINALLY, I was able to get my master and slave devices in the view. And you are right the Save button (unlike what is mentioned in the help) does not show until the devices are selected. In 2014, we should not see such software lapses from NI or German perfectionism with their so called Configurator that I know very well from another product (UPS system)!!!!


Here are two issues:

1. when I use Monitor / Modify tools, the slave is in red i.e. no communication. I have not connected the termination terminals +5V and 0V to anything. Could this be the problem?

2. When I launch ETS_DFP2_DP-SlaveExample (DFP2_DP-SlaveExample does not exist), some labview files (Simple Error  Handler(RT).vi....) are missing.


Since this is my first time ever in any forum, I did not know that I must use the browser refesh button for an update. You replied immediately yesterday while I was trying to get out of mud!!!!


0 Kudos
Message 9 of 13

Hi inmud, 


I have let Comsoft know they need to update their CDs. In general they own those. We do have control over the content on though. If you find errors there let us know and we will update it. 


Are you using the Configurator II or III? Configurator III just came out and there is probably content lacking for it. I believe the save button being greyed out is actually intended behavior, but I do see how it is confusing. I am going to point the Configurator developers to this forum so they get the feedback. 



1) If it isn't communicating there could be any number of issues, but as long as you have the power to the module connected correctly I don't think there will be issues. If you aren't using a profibus cable it will definitely be an issue. 


2) Do a force recompile. The file you are missing is actually a part of labview, not a part of the


Jesse Dennis
0 Kudos
Message 10 of 13