Industrial Communications

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Open DeviceNet interface error when TestStand call VIs of NI PCI-8532

Hello,

 

We use NI PCI-8532 was used as DeviceNet master to do functionality test with a slave (AC Drive).

But when open DeviceNet interface, it happen the error.

We can't find the solution and hope to find help from you.

 

The basic sequence in TestStand is:

1). Call "Open DeviceNet Interface.vi" to open interface and creat interface object.

     Interface(master) setting: interface name=dnet0, MAC ID=0, baudrate=125000bps

2). Call "Open DeviceNet IO.vi" to creat DeviceNet IO object.

     Device(slave) setting: MAC ID=63

3). Call "Operate DeviceNet Interface.vi" and operation code=start

4). Call "Wait For State.vi"

5). Call "Read DeviceNet IO.vi" to read data from IO object

6). Call "Close Object.vi" to close IO object handle

7). Call "Close Object.vi" to close interface object handle

Remark, these DeviceNet VIs locates at "C:\Program Files\National Instruments\LabVIEW 2012\vi.lib\DeviceNet\VIAPI".

 

First time to run sequece in TestStand, it can pass to run step 1) to open DeviceNet interface.

But once there is some error with these steps, and it will happen "Open DeviceNet Interface" error (error code=0xBFF62006) when run these steps again.

 

Then even use LabVIEW DeviceNet example to test, and it happen the same error except restart computer.

The DeviceNet example locates at "C:\Program Files\National Instruments\LabVIEW 2012\examples\NI-Industrial Communications for DeviceNet\Basic Examples\PXI & PCI\MixedCommunication.vi".

Open DeviceNet Interface Error.png

 

Some information more:

PC operate system: Windows XP SP3
LabVIEW version: 2012 SP1

TestStand version: 2012 SP1
PCI 8532 driver version: 2.3.0

Other installed PCI board: PCI 8531 CANOpen

Hardware.png

0 Kudos
Message 1 of 5
(3,981 Views)

Hi,

    Your problems can be resolved by resetting the CAN device.

     http://digital.ni.com/public.nsf/allkb/E79DD867896CABDA862573F50001D994

    

0 Kudos
Message 2 of 5
(3,962 Views)

Question:
ncAction.vi  is used for NI-CAN or NI-DNET.
But I use NI PCI-8532, is it available also?

 

Action:

I have tried with ncAction.vi , but failed.

 

Any comment?

0 Kudos
Message 3 of 5
(3,954 Views)

The following errors may be resolved by resetting the CAN, DeviceNET or LIN device:


Error -1074388986 occurred at ...
NI-CAN:  (Hex 0xBFF62006) The object is already open in another application.  Solutions: Ensure that only one application at a time uses an object , and that you close all objects prior to exiting your application (don't use LabVIEW toolbar's Abort button).

Error -1074388969 occurred at ...
NI-CAN: (Hex 0xBFF62017) This attribute's value must be provided prior to the Open. Solutions: Set the attribute using the Config function before the Open, and do not set the attribute at any later time; Do not configure multiple CAN Objects for the same ID.

 

SO,you should reset the DeviceNet.

 

And another similar issue can explain some points of your problem  http://digital.ni.com/public.nsf/allkb/7D9383E9BEAD0B21862571640002F687?OpenDocument

 

 

0 Kudos
Message 4 of 5
(3,942 Views)

Sorry for bumping this old post but Is there a CAN reset option for newer LabView? Labview 2016? I have this exact error as above "Error -1074388981 occured at Wait for State.vi" 

0 Kudos
Message 5 of 5
(979 Views)