Industrial Communications

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

NI-Industrial Communications for EtherCAT requires I/O Variable Remote Configuration Web Service 1.2 --- regarding a PXIe-8102 RT.

When trying to install IndCom 2.6 or IndCom 2.7 driver on a PXIe-8102 RT, the following error occurs: "Cannot continue because of the following unresolved dependencies: NI-Industrial Communications for EtherCAT requires I/O Variable Remote Configuration Web Service 1.2  Possible reason: The feature's Real-Time support for this target type may not be installed." I've been able to work around this issue with other RT controller models by installing the IndCom driver AFTER I have all the other desired drivers installed. However, that trick does not work on the PXIe-8102. I have many deployments of this system (with various controller models), so upgrading drivers needs to be a last resort. I'm hoping someone can point me to the files needed for this, similar in concept to the files provided in Errors When Remotely Configuring Modules or Variables for the NI 9146 or NI 9148

0 Kudos
Message 1 of 8
(2,723 Views)

It is highly recommended to install drivers after development software and modules. So Installation on your host PC should look like this:

1.LabVIEW development enviroment 

2.LabVIEW Real-Time Module or whatever other modules you are going to use 

3. Drivers , NI-Industrial Communications for EtherCAT driver in your case

 

After host installation is complete you should not have any problems pushing software to your targets. PXIe-8102RT in your case

 

What versions of LabVIEW and LabVIEW Real-time modules do you currently have? 

0 Kudos
Message 2 of 8
(2,714 Views)

I'm using LV 2013 SP1, DAQmx 9.8.0, and RIO 13.1. I've been able to install this driver in the past, even on a PXIe-8102 RT, but I am now having problems. I just tried installing this driver on a PXI-8196 RT and ran into the same issue. I'm guessing something (virus scan? bad HD?) gorched these drivers. I just uninstalled NI-IndCom from my machine and will try reinstalling it.

0 Kudos
Message 3 of 8
(2,710 Views)

You should also try to reformat your controller just to make sure you dont have some corrupted software which might be preventing correct installation.

 

 http://digital.ni.com/public.nsf/allkb/DD1B72485DA949158625784F005DCEF6

0 Kudos
Message 4 of 8
(2,705 Views)

Yep, I've tried that already. No luck. I think something is gorched on my LV development machine. It would be great to know which NI product installers include "I/O Variable Remote Configuration Web Service 1.2". This would tell me what I need to repair/uninstall/reinstall. Without knowing that, I'm just taking my best guess at which products to reinstall to fix this issue. 

0 Kudos
Message 5 of 8
(2,702 Views)

I believe that would be part of NI-RIO 

0 Kudos
Message 6 of 8
(2,700 Views)

NI-RIO was my first guess, but I only ran "Repair". Maybe I need to uninstall it, then install it from scratch.

0 Kudos
Message 7 of 8
(2,698 Views)

Please try installing NI-RIO 13.1 again, but manually select to install Real-Time and Embedded > NI CompactRIO Recommended Software Sets > LabVIEW RT 2013 SP1 Support. Afterwards, you should have the appropriate dependency to install your NI Industrial Communications 2.7. 

 

0 Kudos
Message 8 of 8
(2,669 Views)