Industrial Communications

cancel
Showing results for 
Search instead for 
Did you mean: 

Link speed settings on cRIO don't survive restart

Solved!
Go to solution
Highlighted

I'm running a cRIO-9068 with firmware revision 1.0.0f1.  It's part of a static network whose switch is set to autonegotiate link speeds.  However, if I set the cRIO to autonegotiate link speed, the cRIO fails to connect to the switch.  Pings fail and activity lights on the cRIO and switch show no activity.

 

Curiously, the cRIO successfully connects when I set the link speed to 100Mbps/Full duplex or slower, and this is an acceptable workaround for me (as long as the project requirements don't creep past 100Mbps).  My problem is that this link speed setting does not survive a cRIO restart.  After restart the link speed is reset to autonegotiate, and the cRIO is once again disconnected.

 

I'm trying to make the link speed configuration changes throught the cRIO's web interface.  I'm logged in as admin and saving my changes, and I get confirmation that the link speed was set to 100/FDX.  Despite this, restarts always reset the cRIO to autonegotiate.

 

Another curiosity is the switch's report that the cRIO is connected at 100/HDX.

 

I tried making a script file in /etc/init.d with the command "ethtool -s speed 100 duplex full".  I updated using update-rc.d but no joy.  Whatever NI script is beating mine is either not using ethtool, or it's not in /etc/init.d.  I don't know what else to look for nor where else to look.

 

Changing the switch setting to 100/FDX solves the problem, but this setting is applied to individual ports.  This would force me to always use the same port for the cRIO, a restriction to which I'd rather not commit.

 

The problem is obviously the switch, as the cRIO connects to my development computer just fine with the autonegotiate setting.  Sadly, the switch is a non-negotiable piece of project hardware.  The fix must be done on the cRIO side of things.

 

Any thoughts on why the cRIO doesn't remember it's link speed setting?

 

 

0 Kudos
Message 1 of 10
(3,962 Views)
Highlighted

Hello Reddata;

 

Are you clicking on Save after you change it? Because I did it this way on my cRIO (it's a different model because I don't have a 9068 available) and it keeps the changes I make.

 

Juan B.

National Instruments.

0 Kudos
Message 2 of 10
(3,940 Views)
Highlighted

@Reddata wrote:

[...] I'm logged in as admin and saving my changes, and I get confirmation that the link speed was set to 100/FDX.  Despite this, restarts always reset the cRIO to autonegotiate. [...]

 


 

0 Kudos
Message 3 of 10
(3,931 Views)
Highlighted
Solution
Accepted by topic author Reddata

Good Evening Red,

I found a known bug with this issue reported for LabVIEW 2013. I did a quick test with LV 2014 shows it is work as intended. 

Could you try upgrading to the latest NI-RIO device driver? I couldn't find details of it being fixed so I'm not sure if its on the LabVEW side or the driver side but its worth a shot. 

The car # is 464089 for your records.

 

One more thing you should upgrade to RIO 14.0.1 because there was a bug with disocvered with some components in the FPGA that we fixed that you should upgrade. 

http://digital.ni.com/public.nsf/allkb/90AEA2EB87466CE786257D20005A3A44

Kyle Hartley
Software Engineer
NovaCentrix
Message 4 of 10
(3,924 Views)
Highlighted

Thanks for the help, Kyle.  Unfortunately, I can't update right away (company licensing issues) and am not sure how long I'll have to wait.  I'll revisit this thread once I finally update.

 

For now, I'm going to proceed with the workaround to set the link speed from the switch.

0 Kudos
Message 5 of 10
(3,906 Views)
Highlighted

Red,


I don't know if this helps your licensing issues but RIO 14.0.1 the driver is a free download. You don't need LabVIEW 2014 to use the latest driver. It updates the support files for specific chassis for the latest 4 versions of LabVIEW. I guess I wasn't clear in my previous post the fix most likely distributed by the NI-RIO driver. I'm just not sure which group fixed this currently. 

Kyle Hartley
Software Engineer
NovaCentrix
0 Kudos
Message 6 of 10
(3,900 Views)
Highlighted

@Kyle-H wrote:

You don't need LabVIEW 2014 to use the latest driver.


That's true.  I have LabVIEW 2013, and that's not supported by NI RIO 14.0.1 according to this page: http://digital.ni.com/public.nsf/allkb/577CC9A7DCFC73DF8625738400116CC3

 

I tried installing NI RIO 14.0.1 anyway.  The installer warns me about support being limited to LabVIEW 2013 SP1.

 

I suppose I could continue with the 14.0.1 install, but I'd like to have a plan for rolling back the driver if something goes ascrew.  Can I revert to 13.0.0 at any time?

0 Kudos
Message 7 of 10
(3,815 Views)
Highlighted

Hello!

You should be able to roll back, by reinstalling the past driver, and if it doesnt let you, you can uninstall the version of NI RIO 14.0.1 and then install the one you wish.. Since its a driver it shouldn't give you any issue.

 

Juan B.

National Instruments

Message 8 of 10
(3,798 Views)
Highlighted

Hey Red,

 

To context that KB we don't specifically test the later driver versions with the non-SP1 release because typically SP1 contains bug fixes so if multiple groups need to fix an issue then they synchronize them on a release. Most of the time the later driver will work fine with non SP1 version of the supported releases but we don't test with those specific version. As mentioned you should be able to uninstall RIO 14 if something doesn't work as expected and reinstall RIO 13. But do to the issue I mentioned I'd strongly encourage you to let us know about any issues you experience and we'll try to work with you. 

Kyle Hartley
Software Engineer
NovaCentrix
0 Kudos
Message 9 of 10
(3,790 Views)
Highlighted

Kyle,

 

It works!  I updated to the NI-RIO 14.0.1 driver.  To do that I also had to update the cRIO firmware to 2.1.0f0.  With these updates the problem is resolved: my cRIO maintains its link speed settings between restarts.

 

Thanks!

0 Kudos
Message 10 of 10
(3,770 Views)