Industrial Communications

cancel
Showing results for 
Search instead for 
Did you mean: 

LinMot Ethernet IP six axis servo communication

Highlighted

I have a project I am controlling three LinMot linear rotary motors (PR01 84x240F-C-100).  Each motor requires two drives( B1150-ML-IP), one for the linear axis and one for the rotary axis.  So in all I have six servo drives connected to one control bus module (B8050-ML-IP) that I am communicating with through Ethernet IP.  The bus module is capable of controlling up to eight drives, however I am only using six.  When I am using the Ethernet IP vi's Get Attribute and Set Attribute I get an error when using the instances (16 read & 26 write) LinMot shows to use in their user manual (see the attached Page 20/24).  The manual says I am supposed to be reading 26 bytes and writing 32 bytes per drive, for a total of 156 bytes and 192 bytes respectively for 6 drives.  When I run I am only reading 18 bytes when I should be reading 156 bytes, 26 bytes for each drive.  Also when I attempt to write (instance 26) I get the error as stated earlier (see attached).  I am wondering why I can only read 18 bytes and why I get the error when writing to instance 26.  Also I am using class four attribute three.  

Download All
0 Kudos
Message 1 of 6
(3,777 Views)
Highlighted

Hello Carlssc,

 

I would have liked to suggest you to address your question to this community:

 

“Community: Welcome to EtherNet/IP Industrial Protocol Support”

https://decibel.ni.com/content/thread/7483

 

This because the support for this kind of products is handled in these forum. But I found out that you already posted you question there so It should be started a discussion soon about it with experienced users of these tools.

 

You can also review these other forum posts related to that same error number to check if you can extract something useful from there too:

 

http://forums.ni.com/t5/forums/searchpage/tab/message?filter=labels%2Clocation&location=forum-board%...

 

Best regards,

 

Daniel C.

0 Kudos
Message 2 of 6
(3,730 Views)
Highlighted

Hi carlssc,

 

Can you show a screenshot of the EIP VI you are using? (show the parameters as well as constants if any on the block diagram)

 

 

0 Kudos
Message 3 of 6
(3,724 Views)
Highlighted

It is described in the original post.  Here is an example of the EIP parameters.

0 Kudos
Message 4 of 6
(3,716 Views)
Highlighted

The piece you are showing in the VI screenshot should be correct.

I don't see the other half - Instance ID 26 for writing (Set Attribute Single.vi). I'm not sure if you have set the correct size for the buffer when running. Have you set 192 bytes before running to avoid write failure?

 

 

0 Kudos
Message 5 of 6
(3,634 Views)
Highlighted

Yes the write buffer is 192 bytes and the read is 156 bytes.

0 Kudos
Message 6 of 6
(3,625 Views)