Industrial Communications

cancel
Showing results for 
Search instead for 
Did you mean: 

Industrial Communications for CANOpen Installation Problem

Solved!
Go to solution
Highlighted

Hi,

 

I'm hoping someone can give me some advice. I've been trying to install Industrial Communications for CANOpen on my Laptop. I was running LV2018SP1 (64-bibt) and when I installed Industrial Communications for CANOpen v20.0 when I searched for the CANOpen VIs I couldn't find them. 

 

I uninstalled v20.0 and installed v18.0 (including the 32-bit version). Again I could not find the vi library on my palette (and using the palette search function) but when I looked under the hood I did find the vi library in the Program Files (x86)/National Instruments folder/LabVIEW 2018 folder.

 

I figured it was a compatibility issue so I installed LV2020 and then reinstalled Industrial Communications for CANOpen v20.0  - this removed v18.0 automatically (and the vi libarry I'd found).

 

After this - again I didn't find the vi librabry on the palette. I used the NI Package manager to repair the Industrial Communications for CANOpen v20.0  and still no joy!

 

Can anyone advise? I previously worked with LabVIEW2016 (32-bit) and Industrial Communications for CANOpen v16.0 without any issues as far as I recall  - I need to resurrect this old code for a lab-instrument we are commissioning. I'll move it from my laptop to a PC which has a CANOpen PCI card installed next week.

 

Is my issue the 32-bit vs 64-bit installs? Or did I follow the wrong sequence? Or am I missing some obvious piece of software. If someone can tell me where to find the CANOpen vi library I can probably just install that manually to a palette.....

 

Thanks and advance for your help,

Dave

 

0 Kudos
Message 1 of 2
(87 Views)
Highlighted
Solution
Accepted by topic author DeltaJ

I identified the issue - I needed to install 32-bit LabVIEW rather than 64-bit.

0 Kudos
Message 2 of 2
(17 Views)