Industrial Communications

cancel
Showing results for 
Search instead for 
Did you mean: 

Danfoss fc-102 Modbus TCP communication

I am trying to establish communication with a Danfoss FC-102 inverter through the NI modbus libary.  I constantly get a 'the Modbus slave does not accept the data address contained in the query. Function 3' error. But device identification works.  I try to read for instance the speed which is parameter 1617 which should be address 16170.

Does anyone have experience with Danfoss drives?

The led on the card is blinking indicating that it needs commisioning. But I don't know what parameter still needs to be set.

0 Kudos
Message 1 of 7
(3,382 Views)

Did you have any luck getting communication/control going?

I am just starting an application for this same drive and have made some sense of it but wanted to see where you got with it. The first thing i will say for what you had above is that i think the register you were looking at was a write only, not a read, but again i could be wrong as i have only just started to play with it.

0 Kudos
Message 2 of 7
(3,156 Views)

The register should be a read. But it turns out you have to do x10 and -1 to get the correct register.  Parameter 16-17 should be 16170-1 =16169  This wasn't very clear in the documentation to me.

You can also use the PCD's to map a parameter to the PCD registers.

0 Kudos
Message 3 of 7
(3,137 Views)

Do you have any code you are willing to share? I am talking with the supplier of the drive this afternoon to get more information on which parameters my customer is going to be using as we are reworking a system they used in the past.

0 Kudos
Message 4 of 7
(3,110 Views)

Hi there, for my case before, I've used the USB to RS-485 communication method, which is Modbus RTU protocol. There are some holding register address that couldn't be obtained from the FC itself for unknown reasons. What i've done is, instead of reading the speed, I've tried to read the frequency and convert it to RPM based on the maximum speed of the fan and its setpoint in percentage. It works for me and I've included the test VI for your further reference.

0 Kudos
Message 5 of 7
(3,045 Views)

Hy, so happy to find these topic :-).

Did somebody tried the communication with the PCD registers? I am despairing. I can't read the registers  2910 or any other of these registers. I've set up the maping on parameter 843x. Communication is ok (I can read the other registers like 16299 and so on. Only the PCD registers doesn't work.

Is there someone who can help me?

greetings

Mario

0 Kudos
Message 6 of 7
(139 Views)

perhaps I have to add 666 divide by 7 and kill a black cat or something stupid to get the right registernumber.

0 Kudos
Message 7 of 7
(137 Views)