[IDLE] Grupo de Usuarios LabVIEW - Chile

cancel
Showing results for 
Search instead for 
Did you mean: 

AutoIniciar web service en MyRIO

Hola, ya tengo  funcionando un web service en MYRio pero  no se como lograr  que se inicie luego de energizar la  placa.

Actualmente me  conecto al MYRio mediante  wifi y  arranco el  web service desde el PC, y todo funciona bien, pero si apago  el MYRio tengo que volver a conectarme  desde  el PC para  iniciar el web service.

Agradecería su ayuda.

0 Kudos
Message 1 of 4
(8,169 Views)

hola.

Una pregunta. Tienes todo el código y los servicios corriendo desde el myRIO o tienes algo en el PC?

Intentaste con el ejemplo que menciona este post?

http://forums.ni.com/t5/Academic-Hardware-Products-ELVIS/Publishing-a-web-service-on-NI-My-RIO/m-p/2...

Saludos

Patricio Cortes | NI Cono Sur
Message 2 of 4
(7,189 Views)

Gracias  Patricio, logré  solucionar mi  problema.

Observando el  ejemplo que  citó anteriormente.

En Buid specifications agregué un Real-Time Application y en sus  propiedades apunte  al VI que  necesitaba iniciar durante  el  arranque  del  MyRio. No se  si  es la  forma correcta  o el  mejor  método, pero  es  funcional.

Aca  los enlaces  del  proyecto, es  muy  simple, aunque   quizás  sea  de utilidad para  alguien que quiera  hacer  algo  similar.

 

https://mega.nz/#!d4ZEGDAD

clave de cifrado: !b7afyYTxS-IuvOYcX_akd0KuaoX4YPvCgto4-iyENEw

Message 3 of 4
(7,189 Views)

Me alegra mucho haberte ayudado.

Saludos!

Patricio Cortes | NI Cono Sur
0 Kudos
Message 4 of 4
(7,189 Views)