Hobbyist Toolkit

Showing results for 
Search instead for 
Did you mean: 

Unable to install LINX

Go to solution

Could it be that this functionality has been integrated into the Firmware Wizard? I'm just guessing, never tried to use a target with custom firmware needs (my Linx platform I have worked with was only RasPi so far, and tried once with the Beaglebone Black. But both of them I still work in LabVIEW 2014.

Rolf Kalbermatter
DEMO, TU Delft
My Blog
0 Kudos
Message 11 of 14

It seems like you're right that they changed things up (making previous tutorials less useful and more confusing). When I go in Tools > Hobbyist > Firmware Wizard, and then I go in Settings in the Firmware Wizard, there is a Generate button to generate firmware in the Arduino/libraries folder (along the lines of what tutorials say to do). I set the Arduino Path to C:\Users\cedri\Documents\Arduino\libraries, and I leave the Firmware Base Path as the default C:\Program Files (x86)\National Instruments\LabVIEW 2020\vi.lib\MakerHub\LINX\Firmware, then I click Generate and I get a dialog box that says Done! but then when I try to exit I get the error pasted below and there is nothing new added to the C:\Users\cedri\Documents\Arduino\libraries folder. I appreciate your help. I hope you can guide me through this hurdle. I'm new to all of this.


Something went wrong.

Please try running this wizard again.

If the problem persists please check the wizard settings or post on the LVH LINX Forums at:


Create Folder in LMH-Toolbox.lvlib:Copy File Create Dirs.vi->LMH-LINX.lvlib:Copy Firmware Libraries.vi->LMH-LINX.lvlib:Firmware Wizard Config.vi->LMH-LINX.lvlib:Firmware Wizard.vi<APPEND>

0 Kudos
Message 12 of 14

The path the Create Folder function seems to try to make definitely looks weird in the error message:




Also it seems to want to create a libraries folder already so I would definitely configure the target folder one hierarchy level higher, so only C:\Users\cedri\Documents\Arduino


But if that angled bracket is not just an error reporting issue but rather a real element in the path that that VI tries to create, someone seems to have messed up when constructing the paths! Unfortunately I do not have an Arduino nor a Community Edition installation available at the moment so I can't go into this myself. And yes I know it can be downloaded for free, but the problem is not so much that I can't afford it in terms of money but rather in terms of time available at the moment. 😎

Rolf Kalbermatter
DEMO, TU Delft
My Blog
0 Kudos
Message 13 of 14

I tried C:\Users\cedri\Documents\Arduino instead of C:\Users\cedri\Documents\Arduino\libraries, no luck. I googled this error and couldn't find anything helpful.


I encountered an issue while installing LabVIEW which I overcame by following the suggestion in the post by Carey3255 here:



I'm wondering if excluding the Web Server Development thing is causing the issue with the Firmware Wizard. 


I'm unfortunately having to considering reverting to plan B which is to use Python for my planned data acquisition and GUI work instead of Labview.

0 Kudos
Message 14 of 14