Hobbyist Toolkit

Showing results for 
Search instead for 
Did you mean: 

Unable to install LINX

Go to solution

I downloaded LINX through the VIPM browser, then clicked install. It failed and said try again. So I tried again by right clicking the downloaded version of LINX in my VIPM and clicking install, and then it failed again, and I got the error information below. I'm using Windows 10 and have LabVIEW 2020 SP1 installed.


Main Package Name: Digilent LINX (Control Arduino, Raspberry Pi, BeagleBone and more) v3.0.1.192
Package Name with Error: Digilent LINX (Control Arduino, Raspberry Pi, BeagleBone and more) v3.0.1.192
Error Message: VIPM could not install the package lvh_linx- .
Error Code: 1003
Error Source: Invoke Node in 8F3DEF2215DF2D95EC196F9BE441D656->4FF67890F323272583BCB93B2BA3573D->18F228194448EA2AEE1E68C3AD0B1C9F->OGPM Class.lvlib:6C768C42B6256CFDD71F50FFD4D419DA->OGPM Class.lvlib:F8F9E0CFBA3DFCF36B62FF6A3AE016A6->E9C1F50210230165A53DA48BB2D1F676->VIPM Main Window.vi
Method Name: Run VI

VI Path: C:\Users\cedri\AppData\Local\Temp\PostInstall.vi

0 Kudos
Message 1 of 14
Accepted by CedricE

You got the wrong Linx package. The Digilent package is for LabVIEW 2014. You need the one from NI with version number 1.xxxx. But I was just checking on VIPM and they seem to have pulled that package at the moment. Most likely they are in the process of updating it for LabVIEW 2020 SP1 and smoothing out the many license installation troubles people had recently, so it is likely a temporary absence. The release of this package was done somewhat hastily during the beginnings of the pandemic and there were quite some gotchas you could run into to get it working on your computer.


And you try to install this in a Professional Version of LabVIEW? If you have the Community Edition of LabVIEW, the Linx package should already have been included and installing any other Linx package has an almost certain probability to mess up the installation that came with the Community Edition install.

Rolf Kalbermatter
My Blog
Message 2 of 14

Thanks for your help! I have the community license. I just checked in my NI Package Manager, and there's a package called "LabVIEW Real-Time Module LINX Toolkit Shared Files English". I guess this is LINX and confirms what you said that I should already have it. So if I tried to install a LINX package like mentioned in my original post, will that have screwed up the LINX package that I seem to already have? Should I reinstall LabVIEW? (I'm new to LabVIEW and just installed it yesterday.)

0 Kudos
Message 3 of 14

No, don't install that! If you have the Community Edition you do not need to install Linx separately. Doing so will just mess up your Linx installation that is already included in LabVIEW Community Edition. Since you tried to install it already, there is a very good change that you actually damaged your proper Linx installation with that. This installer was created 5 years ago and had no idea about LabVIEW Linx 2020 so it usually attempts to put some stuff on the system and then concludes that something is pretty amiss, and then throws its hands in the air. Several users in the past only got it back working after that by completely removing LabVIEW Community Edition and any NI software from their computer and start again with a fresh installation.


These packages are only meant for users of the commercial version of LabVIEW. There one needs the NI version of the Linx package and if a user doesn't already have the LabVIEW Real-Time module installed, he also needs to install the extra package that you found in order to add some support files from the Real-Time package that the Linx package reuses.

Rolf Kalbermatter
My Blog
Message 4 of 14

Ok, I had no idea. So should I do a clean uninstall of LabVIEW Community Edition and reinstall it to avoid any potential issues down the road from my attempted LINX install?

0 Kudos
Message 5 of 14

@CedricE wrote:

Ok, I had no idea. So should I do a clean uninstall of LabVIEW Community Edition and reinstall it to avoid any potential issues down the road from my attempted LINX install? 

Yes, that has been the most successful course of action. Anything else usually just causes many hours of frustration.

Rolf Kalbermatter
My Blog
Message 6 of 14

Ok, I'll do the reinstall. Thanks for your help!

0 Kudos
Message 7 of 14

I'm trying to set up an ESP32 microcontroller using these resources:



I'm at the stage toward the end of the instructions in the first link above where I am to use "Generate Firmware Libraries". However, I cannot access this from the Tools menu in LabVIEW because there is no Makerhub option in that menu. Are you sure that I don't need to install LINX-Makerhub? I am certain that I have the community version of LabVIEW. (The clean reinstall went well, by the way.)

0 Kudos
Message 8 of 14

Since NI took over the Linx Toolkit and made it part of their LabVIEW packaging, I'm almost certain that they also changed the name of that menu entry to not use the name Makerhub anymore but something else. Can you find any entry in the tools menu that contains the word Linx?

Rolf Kalbermatter
My Blog
0 Kudos
Message 9 of 14

I looked carefully; there is no entry or subentry in the Tools menu containing the word Linx. (See the attached screenshot for a view of the entries and a couple of subentries in the Tools menu. The tutorial that I'm using for guidance is in the background on the left.)

0 Kudos
Message 10 of 14