Hobbyist Toolkit

cancel
Showing results for 
Search instead for 
Did you mean: 

Sub vi on Raspberry pi

Solved!
Go to solution

Hello everyone.
It has happened to me, several times, that when I use sub VIs in a project, it does not work if it is running in "start up" mode, but it works if I do it from my computer.
I attach an image where you can see the location of the sub VIs in the project and their configuration for the construction of the executable in the Rpi.
I clarify that, if instead of using sub VIs, I make a single great vi, everything works.

Total thanks

Download All
0 Kudos
Message 1 of 2
(424 Views)
Solution
Accepted by topic author Choke

I have tried to reproduce your issue but you should only need to include your main VI as the Startup VIs.  As long as you are calling the subVIs statically they should automatically be included in your build.

 

Once you remove your subVIs from the Startup VI section you can double check each subVI is set to Include if referenced under the Source File Settings but this should be the default setting for any non Startup VI in your project.  Another thing to verify is that the Destination is set to Sam as caller for these subVIs.  If you move them there may be an issue with linking to them properly when building.

 

Source File SettingsSource File Settings

 

Please report back if this does not solve your issue and I will try and reproduce it.

David Wilt
The New Standard LLC
0 Kudos
Message 2 of 2
(368 Views)