Hobbyist Toolkit

cancel
Showing results for 
Search instead for 
Did you mean: 

STEPPER motor starts rotating as i run the program and after certain RPM it stops

Hi there this is Zshan a student of Mechanical Eng.

 

I,m building a control for Stepper Motor Using LINK. Hardware i,m using is Arduino UNO with Driver TB 6560 . As i designed a Block diagram for Controling Stepper(Stepper on/off and. CW/CCW   two buttons) it works fine But issue is when I run Program Motor starts rotating and after Certain RPM it stops and gain control like i can off/on and CW/CCW using buttons. I dont want to start stepper until i Click on Start Button.

 

Note: I have tried to set default values like high and low for both switches. It doesn't works for me.

 

I hope i explained my Problem of you want more info please ask. What could be the reason?

 

If someone can help i really appreciate their help.

Thankyou guys

 

Best regards,

0 Kudos
Message 1 of 3
(893 Views)

here is Shot of Code may be it could help in troubleshooting!

0 Kudos
Message 2 of 3
(888 Views)

Hey Zshan, 

you provided little information.
We can't see how things are wired, or what is really going on. 

if it runs the it stops running, i believe it is something physical, not in software. Does you motor vibrate? Does it have torque? Have you seen if the driver outputs are changing using an oscilloscope? are your arduino outputs working?

Also we cannot debbug imagens, attaching your .VI is much more useful.

TB6560 have 3 inputs but you only mentioned using on/off and CW CCW. 

Also note that Arduino LINX works with poll rates of approximatelly 200hz, that is not enough for fast control. 

i would recommend using a stepper controll library in you arduino and to communicate with LabVIEW you can use LINX with custom commands or even other serial protocol.

Jorge Augusto Pessatto Mondadori, PhD
Sistema Fiep
CLAD, CLD
0 Kudos
Message 3 of 3
(822 Views)