Hobbyist Toolkit

cancel
Showing results for 
Search instead for 
Did you mean: 

Raspberry Pi LINX - Installation Failed

Solved!
Go to solution

Hi all,

 

Just trying to get started with the Raspberry Pi and Labview. Seem to have run into a problem with Installing the software to the Pi.

 

All connects ok, then fails during install. Looks like it can`t access one of the feeds on makerhub. 

 

Anyone know why ?

 

Cheers,

 

Nick

 

 

 

0 Kudos
Message 1 of 5
(747 Views)

Nick,

 

I am not familiar with what the proper log looks like but I question the link to the makerhub.  What version of LabVIEW are you using?

David Wilt
The New Standard LLC
0 Kudos
Message 2 of 5
(729 Views)

At the moment I`m trying to use Labview 2014, I guess the 2020 version might have updated links ...

 

0 Kudos
Message 3 of 5
(725 Views)

I believe that people has still go the LabVIEW 2014 version to work with the makerhub LINX version but you would need to search through this forum to confirm this.

 

My suggestion would be to use the LabVIEW 2020 Community Edition which includes LINX unless you have a specific reason not to do this.

David Wilt
The New Standard LLC
0 Kudos
Message 4 of 5
(720 Views)
Solution
Accepted by NickRH

Hi Nick,

The install wizard for lvrt-schroot (LabVIEW 2014) does not work with the latest version of the PI OS. 

It is possible to install lvrt-schroot from the command line on the Raspberry PI.

 

The problem is with the entry in the file /etc/apt/sources.list

 

It needs to be 

deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
deb [trusted=yes] http://feeds.labviewmakerhub.com/debian/ binary/

 

You can edit the file using the command

 

sudo nano /etc/apt/sources.list

 

AndyLB_0-1622731995063.png

 

 

You can then install lvrt-schroot  with the following commands  (from https://forums.ni.com/t5/LabVIEW/LINX-3-0-on-the-Raspberry-Pi-2-3-and-4-running-Raspbian-Buster/m-p/...)

 

# Install lvrt-schroot for LabVIEW 2014
sudo apt-get update
# Install the LINX package. Error messages will be displayed for the
# nisysserver.service and labview.service sudo apt-get install -y lvrt-schroot # Move the nisysserver.service and labview.service files to the systemctl folder sudo mv /etc/systemd/system/multi-user.target.wants/nisysserver.service /lib/systemd/system sudo mv /etc/systemd/system/multi-user.target.wants/labview.service /lib/systemd/system # link liblinxdevice.so to the Raspberry PI device driver file liblinxdevice_rpi2.so sudo schroot -c labview -d /usr/lib -- ln -s liblinxdevice_rpi2.so liblinxdevice.so # Enable the nisysserver.service and labview.service to start on boot sudo systemctl enable nisysserver.service sudo systemctl enable labview.service # Start the nisysserver.service and labview.service sudo systemctl start nisysserver.service sudo systemctl start labview.service

 

You may need to enable I2C and SPI

 

sudo raspi-config nonint do_i2c 0
sudo raspi-config nonint do_spi 0

 

Cheers,

Andy.

 

Message 5 of 5
(691 Views)