Hobbyist Toolkit

cancel
Showing results for 
Search instead for 
Did you mean: 

New experimental LV RPi/BBB installation feature now available

For years, we have been relying on the Target Configuration dialog to install LabVIEW to Raspberry Pi and BeagleBone Black targets.  This utility works but has some downsides: 1) the target has to have an internet connection available, 2) the target and host machine must be able to communicate with each other on a local network, and 3) the installation process has many steps which can occasionally fail leading to more opportunities for installation errors. 

 

In order to address these issues, we have created an alternative method of installing LabVIEW support to a Raspberry Pi or BeagleBone Black.  The alternative method involves one step: installing an OS image to the target which already includes LabVIEW support. 

 

Note that this is currently an experimental feature, and as such the primarily supported method of installing LabVIEW to support to these targets will be using the Target Configuration dialog. 

 

In the future, even if this new method of installation becomes the primary supported method, we have no plans of removing the Target Configuration dialog  since it will still support more installation scenarios. 

 

For more information on how to use this new experimental feature, see this link: https://github.com/MakerHub/LINX/wiki/Installing-an-image-with-LabVIEW-pre-installed  

Message 1 of 4
(712 Views)

It says 21.0 and 22.3 does this not support 21 SP1 without making changes to the script?

Best Regards
Jonas Mäki
Systems Developer
Novator Solutions
0 Kudos
Message 2 of 4
(568 Views)

Hi Jonas,

 

The 21.0 image supports LV 2021 SP1.

 

Regards,

Ken

0 Kudos
Message 3 of 4
(566 Views)

Good, thank you!

Best Regards
Jonas Mäki
Systems Developer
Novator Solutions
0 Kudos
Message 4 of 4
(562 Views)