Hobbyist Toolkit

cancel
Showing results for 
Search instead for 
Did you mean: 

Labview CE 2020 connects to raspberry but CE 2021 does not

Solved!
Go to solution

Здравствуйте, возникла такая проблема, как запустить и можно ли запустить приложение созданное в лабвью для расбери пи 3 б, нужно сделать так что бы при включении расбери пи мое приложение на лабью сразу работало, пытаюсь реализовать через crontab но не выходит. что делать ?  

0 Kudos
Message 21 of 30
(1,777 Views)

You need to set your application to as Startup.  Checkout this Knowledge article: Difference Between Set As Startup and Run As Startup in My Real-Time Target

David Wilt
The New Standard LLC
0 Kudos
Message 22 of 30
(1,769 Views)

Здравствуйте, хочу создать RT приложения. я работаю с LabVIEW 2020 СЕ and raspberry Pi 3 model b. хочу сделать приложение и загрузить его на распбери, без использования хост машины и лабвью. те приложение должно запускать на распберии при ее подключении к сети питания. пробовал активировать лабвью профессиональное но вылетает ошибка 1498, и установить модуль RT так же не могу вылетает ошибка. а просто создать приложение а закинуть его на распберии не дает результата, пытаюсь через crontab,  активировать автозагрузку но все бестолку. 

0 Kudos
Message 23 of 30
(1,757 Views)

If you have LabVIEW CE installed why are you activating LabVIEW Professional?  If you are using LabVIEW CE you don't need to install the RT module to work with the Raspberry Pi.

 

My suggestion is that you post some images of your exact issue.  Maybe create your own thread as you are asking a different question.

David Wilt
The New Standard LLC
0 Kudos
Message 24 of 30
(1,754 Views)

Здравствуйте у меня такая проблема с ошибкой 1498, нет каталога nisyscfg, для создания RT приложения под распберии пи, как добавить этот каталог я использую LabVIEW 2020 CE, приложение NI System Configuration , скачал, но это не решило проблему. как добавить этот каталог в библиотеку ? скачать предыдущую версию лабвью не могу.!!

0 Kudos
Message 25 of 30
(1,741 Views)

As previously stated, I suggest you make your own ticket with details of what you have does and your exact issue.  Please include screenshots as I am having troubling tracking your exact issue.

David Wilt
The New Standard LLC
0 Kudos
Message 26 of 30
(1,734 Views)

Здравствуйте такая беда случалась были ошибки 1498 не мог создать RT приложение для распберри думал что перустановлю LV и это поможет. удалил софт и теперь не могу его скачать с оф. сайта и установить свой взломанный пакет. что делать впн не помогает. а мне LV очень нужна использую 2020 СЕ. 

0 Kudos
Message 27 of 30
(1,682 Views)

Hi,

 

I've tried to connect a Raspberry Pi to CE 2023 Q1 and get the same problem. Is the solution posted by AndyLB still valid, I would have thought that NI would have rectified the fault by now?

I'm completely new to the Pi, so wanted to ask the question before attempting to correct any problem...

Thanks.

0 Kudos
Message 28 of 30
(1,085 Views)

Hi FelixFire,

The target configuration utility works OK in LabVIEW CE2022 and CE2023 Q1.

What version of Raspberry Pi and PI OS are you using?

 

Here is a link to the supported devices: https://github.com/MakerHub/LINX#readme

 

0 Kudos
Message 29 of 30
(1,040 Views)

Hi,

 

Thanks for the reply.

 

The Raspberry Pi is a "Raspberry Pi 2 Model B Rev 1.1".

I've attached some screen shots of the various stages. When I log into LabView and select Tools>Hobbyist>Target Configuration, the "Connection" section pops up. I can enter the required credentials and the Pi connects, with the Raspberry Icon appearing as shown in the second picture.

The "Installation" section has a blank box for installed version and this never changes, always remaining blank, even after the upgrade has seemingly been accepted.

When I select the "Launch Example", the example pops up and when the run button is pressed, the error message "unable to resolve from current dialog" is displayed as shown in the last picture.

Out of interest Tools>Hobbyist>Firmware Wizard does not provide an option Raspberry Pi; only Arduino, Digilent, PJRC and Sparkfun are listed in the Device Family. Is this correct?

Thanks in advance.

Download All
0 Kudos
Message 30 of 30
(1,022 Views)