Hobbyist Toolkit

cancel
Showing results for 
Search instead for 
Did you mean: 

LV2020Pro + RPi 4 Unable to connect to the target

Solved!
Go to solution

Hi, I'm running into a bit of a wall trying to connect to a Raspberry Pi 4 through the LINX Target Configuration tool in LV2020Pro with LINX toolkit from VIPM installed.  I'm able to SSH into it from my desktop (Win10) but when connecting through the configuration tool, I get "Device interrogation failed: Unable to connect to the target."

 

Background:

- Installed latest Raspberry Pi OS on a 32gb sd card using Raspberry Pi Imager, configured OS

- In Raspberry Pi Configuration, enabled SSH, SPI, I2C, Serial Port, Remote GPIO and disabled Serial Console

- Verified wifi internet connection, visible in router client list

- Attempted to connect through configuration tool from Win10 desktop, get above error message

- Connect RPi 4 to router with ethernet, disable wifi on RPi 4.  Verified cabled internet connection, visible in router client list.

- Attempted to connect through configuration tool, get above error message again

- Following: http://www.diy.ind.in/raspberry-pi/52-raspberry-pi-with-ni-linx-toolkit Opened command prompt, installed LINX, output:

 

Microsoft Windows [Version 10.0.19042.746]
(c) 2020 Microsoft Corporation. All rights reserved.

C:\Windows\system32>ssh pi@192.168.1.156
The authenticity of host '192.168.1.156 (192.168.1.156)' can't be established.
ECDSA key fingerprint is SHA256:fJ2/cS6xni37JMTzG4FUOaf1CiMnI5WSqPjZb/jbDKo.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.1.156' (ECDSA) to the list of known hosts.
pi@192.168.1.156's password:
Linux raspberrypi 5.4.83-v7l+ #1379 SMP Mon Dec 14 13:11:54 GMT 2020 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Thu Jan 21 16:14:26 2021

SSH is enabled and the default password for the 'pi' user has not been changed.
This is a security risk - please login as the 'pi' user and type 'passwd' to set a new password.


Wi-Fi is currently blocked by rfkill.
Use raspi-config to set the country before use.

pi@raspberrypi:~ $ sudo raspi-config nonint do_i2c 0
pi@raspberrypi:~ $ sudo apt-get update
Hit:1 http://archive.raspberrypi.org/debian buster InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian buster InRelease
Reading package lists... Done
pi@raspberrypi:~ $ sudo apt-get dist-upgrade -y
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
pi@raspberrypi:~ $ sudo sh -c 'echo "deb [trusted=yes] http://feeds.labviewmakerhub.com/debian/ binary/" >> /etc/apt/sources.list'
pi@raspberrypi:~ $ sudo apt-get update
Hit:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Ign:2 http://feeds.labviewmakerhub.com/debian binary/ InRelease
Hit:3 http://archive.raspberrypi.org/debian buster InRelease
Ign:4 http://feeds.labviewmakerhub.com/debian binary/ Release
Ign:5 http://feeds.labviewmakerhub.com/debian binary/ Packages
Ign:6 http://feeds.labviewmakerhub.com/debian binary/ Translation-en
Ign:7 http://feeds.labviewmakerhub.com/debian binary/ Translation-en_US.UTF-8
Ign:8 http://feeds.labviewmakerhub.com/debian binary/ Translation-en_US
Ign:5 http://feeds.labviewmakerhub.com/debian binary/ Packages
Ign:6 http://feeds.labviewmakerhub.com/debian binary/ Translation-en
Ign:7 http://feeds.labviewmakerhub.com/debian binary/ Translation-en_US.UTF-8
Ign:8 http://feeds.labviewmakerhub.com/debian binary/ Translation-en_US
Ign:5 http://feeds.labviewmakerhub.com/debian binary/ Packages
Ign:6 http://feeds.labviewmakerhub.com/debian binary/ Translation-en
Ign:7 http://feeds.labviewmakerhub.com/debian binary/ Translation-en_US.UTF-8
Ign:8 http://feeds.labviewmakerhub.com/debian binary/ Translation-en_US
Get:5 http://feeds.labviewmakerhub.com/debian binary/ Packages [709 B]
Ign:6 http://feeds.labviewmakerhub.com/debian binary/ Translation-en
Ign:7 http://feeds.labviewmakerhub.com/debian binary/ Translation-en_US.UTF-8
Ign:8 http://feeds.labviewmakerhub.com/debian binary/ Translation-en_US
Ign:6 http://feeds.labviewmakerhub.com/debian binary/ Translation-en
Ign:7 http://feeds.labviewmakerhub.com/debian binary/ Translation-en_US.UTF-8
Ign:8 http://feeds.labviewmakerhub.com/debian binary/ Translation-en_US
Ign:6 http://feeds.labviewmakerhub.com/debian binary/ Translation-en
Ign:7 http://feeds.labviewmakerhub.com/debian binary/ Translation-en_US.UTF-8
Ign:8 http://feeds.labviewmakerhub.com/debian binary/ Translation-en_US
Ign:6 http://feeds.labviewmakerhub.com/debian binary/ Translation-en
Ign:7 http://feeds.labviewmakerhub.com/debian binary/ Translation-en_US.UTF-8
Ign:8 http://feeds.labviewmakerhub.com/debian binary/ Translation-en_US
Fetched 709 B in 2s (380 B/s)
Reading package lists... Done
pi@raspberrypi:~ $ sudo apt-get install -y lvrt20-schroot
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
libboost-filesystem1.62.0 libboost-iostreams1.62.0 libboost-program-options1.62.0 libboost-system1.62.0 schroot
schroot-common
Suggested packages:
debootstrap lvm2 btrfs-tools aufs-tools | unionfs-fuse qemu-user-static
The following NEW packages will be installed:
libboost-filesystem1.62.0 libboost-iostreams1.62.0 libboost-program-options1.62.0 libboost-system1.62.0
lvrt20-schroot schroot schroot-common
0 upgraded, 7 newly installed, 0 to remove and 0 not upgraded.
Need to get 21.1 MB of archives.
After this operation, 3,630 kB of additional disk space will be used.
Get:1 http://feeds.labviewmakerhub.com/debian binary/ lvrt20-schroot 20.0.0-4 [19.9 MB]
Get:2 http://mirror.sjc02.svwh.net/raspbian/raspbian buster/main armhf libboost-system1.62.0 armhf 1.62.0+dfsg-10+b3 [33.0 kB]
Get:3 http://mirror.sjc02.svwh.net/raspbian/raspbian buster/main armhf libboost-filesystem1.62.0 armhf 1.62.0+dfsg-10+b3 [58.3 kB]
Get:4 http://mirror.sjc02.svwh.net/raspbian/raspbian buster/main armhf libboost-iostreams1.62.0 armhf 1.62.0+dfsg-10+b3 [50.2 kB]
Get:5 http://mirror.sjc02.svwh.net/raspbian/raspbian buster/main armhf libboost-program-options1.62.0 armhf 1.62.0+dfsg-10+b3 [137 kB]
Get:6 http://mirror.sjc02.svwh.net/raspbian/raspbian buster/main armhf schroot-common all 1.6.10-6 [244 kB]
Get:7 http://mirror.sjc02.svwh.net/raspbian/raspbian buster/main armhf schroot armhf 1.6.10-6 [676 kB]
Fetched 21.1 MB in 4s (5,241 kB/s)
Selecting previously unselected package libboost-system1.62.0:armhf.
(Reading database ... 98448 files and directories currently installed.)
Preparing to unpack .../0-libboost-system1.62.0_1.62.0+dfsg-10+b3_armhf.deb ...
Unpacking libboost-system1.62.0:armhf (1.62.0+dfsg-10+b3) ...
Selecting previously unselected package libboost-filesystem1.62.0:armhf.
Preparing to unpack .../1-libboost-filesystem1.62.0_1.62.0+dfsg-10+b3_armhf.deb ...
Unpacking libboost-filesystem1.62.0:armhf (1.62.0+dfsg-10+b3) ...
Selecting previously unselected package libboost-iostreams1.62.0:armhf.
Preparing to unpack .../2-libboost-iostreams1.62.0_1.62.0+dfsg-10+b3_armhf.deb ...
Unpacking libboost-iostreams1.62.0:armhf (1.62.0+dfsg-10+b3) ...
Selecting previously unselected package libboost-program-options1.62.0:armhf.
Preparing to unpack .../3-libboost-program-options1.62.0_1.62.0+dfsg-10+b3_armhf.deb ...
Unpacking libboost-program-options1.62.0:armhf (1.62.0+dfsg-10+b3) ...
Selecting previously unselected package schroot-common.
Preparing to unpack .../4-schroot-common_1.6.10-6_all.deb ...
Unpacking schroot-common (1.6.10-6) ...
Selecting previously unselected package schroot.
Preparing to unpack .../5-schroot_1.6.10-6_armhf.deb ...
Unpacking schroot (1.6.10-6) ...
Selecting previously unselected package lvrt20-schroot.
Preparing to unpack .../6-lvrt20-schroot_20.0.0-4_armhf.deb ...
Unpacking lvrt20-schroot (20.0.0-4) ...
Setting up libboost-program-options1.62.0:armhf (1.62.0+dfsg-10+b3) ...
Setting up libboost-system1.62.0:armhf (1.62.0+dfsg-10+b3) ...
Setting up schroot-common (1.6.10-6) ...
Setting up libboost-filesystem1.62.0:armhf (1.62.0+dfsg-10+b3) ...
Setting up libboost-iostreams1.62.0:armhf (1.62.0+dfsg-10+b3) ...
Setting up schroot (1.6.10-6) ...
Created symlink /etc/systemd/system/multi-user.target.wants/schroot.service → /lib/systemd/system/schroot.service.
Setting up lvrt20-schroot (20.0.0-4) ...
Processing triggers for systemd (241-7~deb10u5+rpi1) ...
Processing triggers for man-db (2.8.5-2) ...
Processing triggers for libc-bin (2.28-10+rpi1) ...
pi@raspberrypi:~ $ sudo mv /etc/systemd/system/multi-user.target.wants/nisysserver.service /lib/systemd/system
pi@raspberrypi:~ $ sudo mv /etc/systemd/system/multi-user.target.wants/labview.service /lib/systemd/system
pi@raspberrypi:~ $ sudo schroot -c labview -d /usr/lib -- ln -s liblinxdevice_rpi2.so liblinxdevice.so
ln: liblinxdevice.so: File exists
pi@raspberrypi:~ $ sudo systemctl enable nisysserver.service
Created symlink /etc/systemd/system/multi-user.target.wants/nisysserver.service → /etc/systemd/system/nisysserver.service.
pi@raspberrypi:~ $ sudo systemctl enable labview.service
Created symlink /etc/systemd/system/multi-user.target.wants/labview.service → /etc/systemd/system/labview.service.
pi@raspberrypi:~ $ sudo systemctl start nisysserver.service
pi@raspberrypi:~ $ sudo systemctl start labview.service

 

- Attempted to connect again with configuration tool, same error

- RPi 4 also not visible when trying to add a target to a project

- I do get a message from the LINX Target Configuration tool saying "This wizard will install LabVIEW 2014 support to the target device.  You will only be able to connect to and use the device from LabVIEW 2014." Can I not connect using LV2020Pro?

 

Any help is appreciated.  Thank!

 

 

0 Kudos
Message 1 of 13
(663 Views)

In short you can connect to a RPi with LabVIEW 2020 Professional.  I have done this on an RPi 3.

 

What NI software do you have installed?  I found that I was not able to target my RPi in a project until after I installed LabVIEW Real-time.

David Wilt
The New Standard LLC
0 Kudos
Message 2 of 13
(654 Views)

Here is my post on my experience setting up LabVIEW 2020 Professional and the RPi 3.

 

https://forums.ni.com/t5/LINX/LabVIEW-2020-Professional-Required-Software-for-Raspberry-Pi/td-p/4099...

David Wilt
The New Standard LLC
0 Kudos
Message 3 of 13
(643 Views)

Currently running 20.0.1 32-bit, also have Real-time module installed, as well as some other modules.  Also have another 2019 installation, but not running that in this instance.

0 Kudos
Message 4 of 13
(641 Views)

I get the same error you initially indicate in that link when trying to open that project, however, I do have Real-time 2020 installed.

0 Kudos
Message 5 of 13
(623 Views)
Solution
Accepted by topic author FKhueson

The prompt about 2014 makes me think that you have the wrong version of LINX installed.  I would uninstall what you have and make sure you install the 2020 version from VIPM.

 

Another thought would be start over with the RPi OS and make the minimum changes to the setup before connecting with LabVIEW.  Maybe a change you made is interfering.

David Wilt
The New Standard LLC
0 Kudos
Message 6 of 13
(620 Views)

Well if you are getting the same error I was but you say you have Real-time installed then what is different with what I have installed and what you have installed?

 

I have never had good luck with multiple versions of LabVIEW on the same system.

David Wilt
The New Standard LLC
0 Kudos
Message 7 of 13
(617 Views)

I had tried uninstalling and reinstalling LINX from VIPM, same issue.  I do have 2019 and 2020 installed, as I've got some applications deployed using 2019.  As far as differences in our installations, I have quite a few other modules installed, both 2019 and 2020 versions, but I haven't had any issues with them interfering with LINX when connecting with Arduinos in 2019.  I can try reinstalling the OS on the Pi, but I don't think I'd modified anything out of the ordinary when setting it up prior to trying to connect.  Will report back.

0 Kudos
Message 8 of 13
(611 Views)

Tried reinstalling RPi OS, enabled SSH, connected over ethernet, same error.  It seems like its some issue with LabVIEW as I can SSH in no problem.  Tried uninstalling the LINX toolkit from 2019, still same error.  As well, the same error you described in your link persists, where the target displays an error in the project.  Checked my licenses for RT2020 and LV2020, both are alright.  Running everything as admin... kind of scratching my head staring at this.  The prompt about LV2014 is concerning, but I don't think there's another version of LINX that I can install (3.0.1.192).

0 Kudos
Message 9 of 13
(599 Views)
Solution
Accepted by topic author FKhueson

You are using the wrong version of LINX I think

 

you need the one highlighted for LV2020

jdebuhr_0-1611330243838.png

 

I have found so far that the IO lines work with RPi 4 but the Serial does not. infact the Serial I have found to only work on RPi 2.. it will not work on RPi 3 or RPi 4

 

Jeff D.

Certified Architect LabVIEW Champion DQMH Framework

0 Kudos
Message 10 of 13
(546 Views)