Hobbyist Toolkit

cancel
Showing results for 
Search instead for 
Did you mean: 

LINX and Raspberry Pi4 Mis-identification Issues

ROlf,

 

I am looking forward to what you are developing. after reading through the thread I am sort fo glad Iam not alone with the issues with the RPi3 and RPi4 ( in my case serial use).

 

Sounds like you might have some of that resolved in what you are creating.. 

 

Jeff D.

Certified Architect LabVIEW Champion DQMH Framework

0 Kudos
Message 21 of 28
(474 Views)

I was trying to get back with this for LabVIEW 2020. HAd a nice VMWare image with LabVIEW 2020 and thought it would be cool to upgrade that to LabVIEW 2020 SP1. NOT!

Now LabVIEW crashes silently about 2 seconds after starting up and showing the splash screen. No crash dialog, nothing! It just shows the splash screen and poof, it's gone.

 

Going to deinstall all NI related stuff and reinstalling SP1 from scratch. Keep fingers crossed.

Rolf Kalbermatter
Averna BV
0 Kudos
Message 22 of 28
(465 Views)

in labview use linx , all the labview vis ,only digital write and read functions can run successfully,.

other vis report error , such as pwm. spi . iic.

0 Kudos
Message 23 of 28
(435 Views)

Hey Rolf, Ever get any further? It is kind of unfortunate that NI was talking about LabVIEW and RPi yet several things don't work ON THE RPi 3 and 4

Jeff D.

Certified Architect LabVIEW Champion DQMH Framework

0 Kudos
Message 24 of 28
(351 Views)

Hello. Anyone was able to make the Pi 4 work properly? I'm in this issue about 2 weeks, and always end with nothing. Thanks

0 Kudos
Message 25 of 28
(121 Views)

@ricardosteffens wrote:

Hello. Anyone was able to make the Pi 4 work properly? I'm in this issue about 2 weeks, and always end with nothing. Thanks


Yes, I am working with both a RPi3 and RPi4.  I can swap the SD cards between the 2 and it works on both.  The only issue I have seen is it appears the program may stop running on the RPi4 after a period of time, days of continuous execution, but I have not looked into this to determine what is going on.  I power cycler always starts the program again.  I do not see this on the RPi3 I have.

David Wilt
The New Standard LLC
0 Kudos
Message 26 of 28
(117 Views)

Very nice. I was able to make the serial work fine in PI 4?

0 Kudos
Message 27 of 28
(108 Views)

@ricardosteffens wrote:

Very nice. I was able to make the serial work fine in PI 4?


I am not using serial at this time so I can't provide any input on that.  I would suggest making a new post with your exact issue to try and get some help.

David Wilt
The New Standard LLC
0 Kudos
Message 28 of 28
(104 Views)